Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Nexus 5 won't get 3G or 4G network

OP warsylep

19th January 2015, 07:08 PM   |  #41  
Junior Member
Flag Tbilisi
Thanks Meter: 0
 
5 posts
Join Date:Joined: Nov 2012
More
Unhappy
I have the same issue. Only EDGE. But this happened today, network was working just fine, but today I dropped my phone and after couple of hours when I wanted to surf the web, I noticed that there was only E( EDGE) on status bar :/ So I got home, put my sim-card in my mom's smartphone and it's on 3G just like it should be. Then I inserted my mom's simcard in my N5, and I got the same EDGE signal. Kinda confused. I'm unlocked and on Lollipop. And the warranty is due already

any help?
26th January 2015, 09:43 AM   |  #42  
spupuz's Avatar
Senior Member
Flag Milan
Thanks Meter: 257
 
1,741 posts
Join Date:Joined: Feb 2008
Donate to Me
More
Quote:
Originally Posted by porga

I have same issue, which started a week ago. In area 30 kilometers from home, where I work, i get LTE signal. But at home or on the way to work i get Edge only. However HSPA appears prom time to time, for example today when i was several hundred meters from antenna. I do not know is this is hardware issue, should I carry it to service?

same problem for me :/
Post Reply Subscribe to Thread

Tags
lte, nexus 5, wcdma
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes