Post Reply

[Q] Nexus 5 won't show in web Google Play "My Devices"

OP Caddish

30th March 2014, 10:30 PM   |  #1  
OP Member
Thanks Meter: 1
 
53 posts
Join Date:Joined: Apr 2011
Hello, as the title says, I've had my Nexus 5 (which I love btw) for 4 days and it still does not show in the web version of the Play store (https://play.google.com/settings). I have tried clearing the Play Store data in android but it does not work, any other idea ?
31st March 2014, 06:32 AM   |  #2  
xdrc45's Avatar
Senior Member
Flag Great White , Michigan
Thanks Meter: 293
 
723 posts
Join Date:Joined: May 2012
More
Quote:
Originally Posted by Caddish

Hello, as the title says, I've had my Nexus 5 (which I love btw) for 4 days and it still does not show in the web version of the Play store (https://play.google.com/settings). I have tried clearing the Play Store data in android but it does not work, any other idea ?

I haven't been in my play setting in a while but I just checked and it's displayed... Mfg -LGE - Model- Nexus 5 -
Carrier - T-Mobile. (Even though it was ordered from the Play store) and it even shows that is was registered on 3/22 which actually was when I just flash a new ROM on it.
Seems like it should be displayed immediately and I would think that after 4 days it would be displayed.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Nexus 5 Q&A, Help & Troubleshooting by ThreadRank