FORUMS

Analysis & Opinion

[Q] Painfully slow charging

18 posts
Thanks Meter: 0
 
By Tornado54, Junior Member on 12th June 2014, 03:18 AM
Post Reply Subscribe to Thread Email Thread
My Nexus 5 was updated to 4.4.3 a few days ago. Since yesterday I am noticing problems with the charging. My phone only charged 50% over 8 hours. I am using the OEM wall charger with OEM cable.

I downloaded the battery monitor widget and it shows charge at 292ma I even tried switching the phone off but that didn't help either. Do i need to RMA the phone? I would have preferred not doing that as I just applied a glass screen protector but if I have no other choice I guess I will just have to suck it up and do it.
 
 
12th June 2014, 04:04 AM |#2  
Member
Flag Curitiba
Thanks Meter: 26
 
Donate to Me
More
Quote:
Originally Posted by Tornado54

My Nexus 5 was updated to 4.4.3 a few days ago. Since yesterday I am noticing problems with the charging. My phone only charged 50% over 8 hours. I am using the OEM wall charger with OEM cable.

I downloaded the battery monitor widget and it shows charge at 292ma I even tried switching the phone off but that didn't help either. Do i need to RMA the phone? I would have preferred not doing that as I just applied a glass screen protector but if I have no other choice I guess I will just have to suck it up and do it.

My guess it's probably the charger.
Try pluging it to the computer USB port, and also if does not work, try chaing the micro usb cable and test again using computer.
12th June 2014, 04:16 AM |#3  
OP Junior Member
Thanks Meter: 0
 
More
I tried two chargers and had the same issue with both. Will try the computer. I also did a hard data reset and the problem continues
12th June 2014, 07:59 AM |#4  
Junior Member
Thanks Meter: 0
 
More
I have experienced it too.. I charged more than 7 hours just to charge the phone 100%. Any idea whats going on? I have factory reset it




Quote:
Originally Posted by Tornado54

My Nexus 5 was updated to 4.4.3 a few days ago. Since yesterday I am noticing problems with the charging. My phone only charged 50% over 8 hours. I am using the OEM wall charger with OEM cable.

I downloaded the battery monitor widget and it shows charge at 292ma I even tried switching the phone off but that didn't help either. Do i need to RMA the phone? I would have preferred not doing that as I just applied a glass screen protector but if I have no other choice I guess I will just have to suck it up and do it.

12th June 2014, 01:46 PM |#5  
Junior Member
Thanks Meter: 0
 
More
Same issue is happening to me also after upgrading my nexus5 to 4.4.3
I noticed the charging is painfully slow (it's even slower than charging the phone using USB cable from a computer / laptop).

Standard ROM, OEM charger.
12th June 2014, 05:20 PM |#6  
Senior Member
Flag Toronto
Thanks Meter: 454
 
More
Quote:
Originally Posted by Tornado54

My Nexus 5 was updated to 4.4.3 a few days ago. Since yesterday I am noticing problems with the charging. My phone only charged 50% over 8 hours. I am using the OEM wall charger with OEM cable.

I downloaded the battery monitor widget and it shows charge at 292ma I even tried switching the phone off but that didn't help either. Do i need to RMA the phone? I would have preferred not doing that as I just applied a glass screen protector but if I have no other choice I guess I will just have to suck it up and do it.

Does it say charging USB or charging AC?

Sent from my Nexus 5 using Tapatalk
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes