Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Pictures take forever to load on wifi

OP Chad_Petree

6th February 2014, 11:35 AM   |  #1  
Chad_Petree's Avatar
OP Senior Member
Flag Berlin
Thanks Meter: 172
 
2,380 posts
Join Date:Joined: Apr 2009
More
I confirmed I have the slow "slow WiFi bug " , I have a 100 Mbps connection but with my nexus 5 I can only get between 15 and 30mbps (on a good day ) , the thing is 15 Mbps should still be good enough , when I load websites , even websites full of images like the www.theverge.com they load almost instantly but instagram , Facebook , klyph take forever to load (at least 35 seconds ) , as soon as I switch to LTE they load instantly is anyone else having a similar issue ?

Sent from my Nexus 5 using Tapatalk
6th February 2014, 03:23 PM   |  #2  
Senior Member
Thanks Meter: 52
 
282 posts
Join Date:Joined: Mar 2011
Quote:
Originally Posted by Chad_Petree

I confirmed I have the slow "slow WiFi bug " , I have a 100 Mbps connection but with my nexus 5 I can only get between 15 and 30mbps (on a good day ) , the thing is 15 Mbps should still be good enough , when I load websites , even websites full of images like the www.theverge.com they load almost instantly but instagram , Facebook , klyph take forever to load (at least 35 seconds ) , as soon as I switch to LTE they load instantly is anyone else having a similar issue ?

Sent from my Nexus 5 using Tapatalk

I'd lean towards this being an issue with your wifi router. Have you tried on another wifi that has a decent connection?
8th February 2014, 02:05 PM   |  #3  
Chad_Petree's Avatar
OP Senior Member
Flag Berlin
Thanks Meter: 172
 
2,380 posts
Join Date:Joined: Apr 2009
More
Quote:
Originally Posted by bekyndnunwind

I'd lean towards this being an issue with your wifi router. Have you tried on another wifi that has a decent connection?

Not , yet I'm gonna go to my friend's place to see how it works over there , this situation is really annoying

Sent from my Nexus 5 using Tapatalk
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes