Post Reply

PIN+Swiftkey= locked+Floating Toucher=overiding security=weirdest xperience

12th June 2014, 10:12 AM   |  #1  
OP Junior Member
Flag Navi Mumbai
Thanks Meter: 0
 
7 posts
Join Date:Joined: Jan 2012
More
hi

yesterday i had faced very weird problem with nexus 5 (rooted with CF-Auto root).. it got locked on me.
What happened was i installed swiftkey on my nexus 5. I had to go out and battery was low so I turned off mobile data and kept it for charging. I dont really lock my nexus when I am at home but whenever I go out I set up PIN for security and its been the same 4 digits number since my first android cell. So this time I went into settings=>Security and set it up. The only change was that instead of usual keyboard, swiftkey opened. So I inserted the number twice.. Nothing weird so far.. right ?...

Well, what happened after that was weird.. I couldnt unlock my nexus. No matter how many time I tried I couldnt unlock it. I can swear that I inserted my usual PIN but it wouldnt unlock. Then I started panicking. After few unsuccessful attempts the usual prompt came so I waited 30 secs and tried again. But no avail. So there was no option but to recover password via gmail, right ? well I wasnt that lucky.. I tried wrong pin for more than 50 times but "forgot password" prompt wouldnt come. (i hadnt taken nandroid backup for last 2 months so i started getting mini heart attacks ) then I tried 40-50 times more.. restarted my cell 3-4 times.. neither would it get locked not it would give me alternate method of unlocking.. thats stupid right ??

I couldnt do anything. I checked online and found out that KITKAT DOESNT HAVE ALTERNATIVE OPTION of locking (or unlocking for that matter). Since my mobile data was off (I dont have wifi) I couldnt lock and unlock it using Android Device Manager (ADM) as well. So I was royally screwed ... and only apparent way out would entail data loss

I could just use camera and nothing else.

So I slept badly thinking that I would factory reset my nexus the next day. And in the morning it suddenly hit me . I had also installed Floating Toucher app yesterday and I could see the floater even on my camera app. So I touched that.. opened quick launch and enabled mobile data. Then went on and locked my nexus using ADM and then I could unlock it with new password. phew...


so it was in all weirdest experience.
Now here are my findings
1) KitKat doesnt have alternative unlocking method
2) Nor does it lock your cell permanently. I mean you could try all permutations and combinations till you unlock it. (my ancient nokia would lock after few wrong tries..) and thats serious flow in system
3) Swiftkey may have screwed me over.
4) Floating Toucher (though proved as my saviour) could bypass system lock and thus one could use (or misuse) it.

Any thoughts on these people ??
12th June 2014, 10:51 AM   |  #2  
OP Junior Member
Flag Navi Mumbai
Thanks Meter: 0
 
7 posts
Join Date:Joined: Jan 2012
More
Smile Sorry for looooooong post
and sorry for toooooooo long post. I couldnt wrap it up without telling everything.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Nexus 5 Q&A, Help & Troubleshooting by ThreadRank