Post Reply

Slow download speed after rooting?

OP Pawelss

14th March 2014, 11:32 AM   |  #1  
OP Member
Thanks Meter: 8
 
79 posts
Join Date:Joined: Aug 2009
hey dear community,

I am a proud Nexus 5 owner, but I hate stock ROMs and I love how many new, useful features custom ROMs pack.
I rooted my phone yesterday (note, this is the D821 device), unlocking the bootloader and rooting the stock rom went perfectly fine, however, when I flashed a custom ROM, the storage was wiped along with the system and it wouldnt boot up, so I went back to stock (I could access the recovery and bootloader, it wouldnt wipe, it would only give me storage mount errors and while mounting storage via the recovery it would show 0kb), this went smooth as well, so I decided that since I have lost my data anyways, I should give it a try and root it again. Root was successful, flashing a custom ROM too, I was happy as ever with many functions that I wished, I installed all of my apps, set the stuff up and so on (everything via WiFi). After that I had to leave and therefore disconnect the WiFi, now that's where the problem occurs, when I try to download anything from the net (even play store) the download speed doesnt even reach 30kb/sec. I tested it with speedtest apps from play store, download wouldnt reach 0.30mbps, while upload was at ~3mbps. I'm really confused at this point, could it be caused by the radio I flashed? (I used a tutorial on how to get back to stock) or is it a carrier issue and it's just a coincidence that I rooted the device when they have some issues? WiFi speeds are perfectly fine.
I also seem to have an issue with switching between networks (eg 2g -> 3g -> 4g)

this is the ROM I am using right now: http://forum.xda-developers.com/show....php?t=2606917
this is the tutorial I used to get back to stock: http://forum.xda-developers.com/show....php?t=2513701

I did not check the download speeds on STOCK ROM after returning to stock.
also websites load very fast too.

thanks for reading

edit: it doesnt seem to be ROM related, I flashed another ROM (http://forum.xda-developers.com/show....php?t=2525627) and the download speed is still slow.
Last edited by Pawelss; 14th March 2014 at 12:26 PM.
14th March 2014, 01:00 PM   |  #2  
meangreenie's Avatar
Senior Member
Thanks Meter: 644
 
2,220 posts
Join Date:Joined: Mar 2012
edit... whoops, apologies..I completely misread your post.
Last edited by meangreenie; 14th March 2014 at 06:00 PM.
14th March 2014, 03:03 PM   |  #3  
Senior Member
Flag Cullompton
Thanks Meter: 95
 
258 posts
Join Date:Joined: Dec 2012
More
I can't see how root would slow your data down. Are you sure your phone network isn't throttling your speed? Do you have unlimited data with a fair usage policy?

Sent from my Nexus 5
14th March 2014, 05:17 PM   |  #4  
OP Member
Thanks Meter: 8
 
79 posts
Join Date:Joined: Aug 2009
Quote:
Originally Posted by meangreenie

Turn off mobile data and wifi on the phone, then restart WiFi only... now do a speed check.

thanks for your reply, I tried your method but it didnt seem to affect my speed at all
I tested the speed on WiFi and I get ~41mbps download and 7mbps upload (thats how it should be with my connection)

Quote:
Originally Posted by pepdavies

I can't see how root would slow your data down. Are you sure your phone network isn't throttling your speed? Do you have unlimited data with a fair usage policy?

Sent from my Nexus 5

Im not limited with my data plan. The speed wouldnt go down no matter what, I've used the same plan for years now and this has never occured before. but Orange recently upgraded their antennas to 4G/LTE so it might be a thing on their side.
I did more research, when I'm on 4g network, the speed is normal, I get 11mbps downs and 3mbps ups, but when it switches to hsdpa or hsdpa+, the download speed goes down so badly that I cant download anything. note that websites load as fast as it should and it should be affected by download speed, right?

I cant see how root could affect it either, but maybe there's an issue with the radio I flashed when I flashed stock ROM back. On the other hand the only thing it COULD possibly affect would be 4g as the US version has different bands for 4g only.
I'm pretty sure it's a carrier issue and it's a malfunction on their side, but I found it quite disturbing that mobile data doesnt work the way it should just after I rooted and flashed a custom ROM.
15th March 2014, 12:31 AM   |  #5  
OP Member
Thanks Meter: 8
 
79 posts
Join Date:Joined: Aug 2009
I switched the simcard with my dads t-mobile, and the download speeds went up to 19mbps on my nexus 5, but at the same time when I tried my simcard in his nexus 4, the speed was good too, but it happened before, so I suppose it's my carrier's fault

and of course I had to switch the simtrays and get it stuck in my nexus 5 I had to tear it down to get it out :P
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Nexus 5 Q&A, Help & Troubleshooting by ThreadRank