Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,728,571 Members 54,435 Now Online
XDA Developers Android and Mobile Development Forum

Slow Reboot

Tip us?
 
alamarco
Old
#1  
alamarco's Avatar
Member - OP
Thanks Meter 19
Posts: 55
Join Date: Jan 2013
Default Slow Reboot

I have two applications that are slow to start after a reboot. They are Dashclock and Lightflow.

With regards to Dashclock, as soon as my device has reboot it displays nothing on the lockscreen for roughly a minute. I can unlock the device, use it, lock it and still nothing until it finally loads.

Same issue with Lightflow. My device will boot up and I won't get the notification that it is running until roughly a minute in.

The only other app I have starting up is Lux and Lux starts up fine with the device. I've tried uninstalling and re-installing Dashclock and Lightflow, but no success.

This morning was the day I rooted my device. I unlocked, which wiped all data, installed TWRP and then installed root. After all that was finished I re-installed all my apps and started getting all my apps configured again.

Is this slowdown related to root opening up new locations such as data?

Is there anything can speed this up? It's strange that Lux starts up properly while the other two do not.

I'm going to try searching some more and looking into it, but thus far I've not found anything. Since I can't find much, it seems like this isn't a common issue with either application.

I'm using a Nexus 5.
 
Aerowinder
Old
#2  
Recognized Contributor
Thanks Meter 1191
Posts: 3,019
Join Date: Aug 2012
Quote:
Originally Posted by alamarco View Post
I have two applications that are slow to start after a reboot. They are Dashclock and Lightflow.

With regards to Dashclock, as soon as my device has reboot it displays nothing on the lockscreen for roughly a minute. I can unlock the device, use it, lock it and still nothing until it finally loads.

Same issue with Lightflow. My device will boot up and I won't get the notification that it is running until roughly a minute in.

The only other app I have starting up is Lux and Lux starts up fine with the device. I've tried uninstalling and re-installing Dashclock and Lightflow, but no success.

This morning was the day I rooted my device. I unlocked, which wiped all data, installed TWRP and then installed root. After all that was finished I re-installed all my apps and started getting all my apps configured again.

Is this slowdown related to root opening up new locations such as data?

Is there anything can speed this up? It's strange that Lux starts up properly while the other two do not.

I'm going to try searching some more and looking into it, but thus far I've not found anything. Since I can't find much, it seems like this isn't a common issue with either application.

I'm using a Nexus 5.
Are you on ART?
 

Google Firmware: Google
USB Drivers: Google | Mirror
ADB+ADB Drivers: 19.0.2 (4.4.4) + Koush Universal ADB Drivers

TWRP Official: hammerhead | flo
TWRP Holofied: hammerhead | flo

Gapps: BaNkS

Superuser: Chainfire | Mirror
 
alamarco
Old
#3  
alamarco's Avatar
Member - OP
Thanks Meter 19
Posts: 55
Join Date: Jan 2013
Quote:
Originally Posted by Aerowinder View Post
Are you on ART?
No, I'm on dalvik. Haven't touched ART at all.

Some more information, it seems this isn't related to Dashclock or Lightflow. The default lockscreen will show the clock on reboot, but the date and alarm underneath don't show up for roughly a minute.

Are there logs anywhere that could help pinpoint the delay?
 
bblzd
Old
#4  
Senior Member
Thanks Meter 251
Posts: 1,168
Join Date: Nov 2013
Location: Toronto
I've noticed the same thing with dashclock. Stock dalvik.

Sent from my Nexus 5 using Tapatalk
W32
 
rootSU
Old
#5  
rootSU's Avatar
Senior Member
Thanks Meter 9721
Posts: 20,882
Join Date: Aug 2010
Location: Oxenhope, West Yorkshire, UK
Loads of Apps have to start up. Its common for some to be delayed. Further more, many will have dependencies on other system processes that need to start up first.

Its normal and there's not a lot to be done about it

-----------------------
Sent via tapatalk.

I do NOT reply to support queries over PM. Please keep support queries to the Q&A section, so that others may benefit
Want to root/unroot? All important guides and info threads are contained within the "Sticky Roll-up" thread in General. Click the link below to get there!



Philz Touch Recovery with passkey secure lock

I do NOT reply to support queries over PM.
The Following User Says Thank You to rootSU For This Useful Post: [ Click to Expand ]
 
alamarco
Old
#6  
alamarco's Avatar
Member - OP
Thanks Meter 19
Posts: 55
Join Date: Jan 2013
Quote:
Originally Posted by rootSU View Post
Loads of Apps have to start up. Its common for some to be delayed. Further more, many will have dependencies on other system processes that need to start up first.

Its normal and there's not a lot to be done about it
That's understandable. I just found it weird that it behaved differently from non-root to root. Especially with Dashclock since you're greeted with nothing except for the lock pattern upon boot.
 
Wergin
Old
#7  
Member
Thanks Meter 6
Posts: 63
Join Date: Jan 2014
May be this coz of any type of virus In application.
Or in Your Phone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Easily Combine Text and Manage Your Android Clipboard with StuffMerge

Android clipboard management has always been impractical without the … more

Pale Moon Browser Ported to Android

Having a wide choice of third party applications is one of the most beautiful things that Android has to … more

Partial Android Wear Source Uploaded to AOSP

2014 is certainly shaping up to be theyear of the wearables. And thanks to its innovative … more