5,605,438 Members 43,198 Now Online
XDA Developers Android and Mobile Development Forum

Slow Reboot

Tip us?
 
alamarco
Old
#1  
alamarco's Avatar
Member - OP
Thanks Meter 19
Posts: 55
Join Date: Jan 2013
Default Slow Reboot

I have two applications that are slow to start after a reboot. They are Dashclock and Lightflow.

With regards to Dashclock, as soon as my device has reboot it displays nothing on the lockscreen for roughly a minute. I can unlock the device, use it, lock it and still nothing until it finally loads.

Same issue with Lightflow. My device will boot up and I won't get the notification that it is running until roughly a minute in.

The only other app I have starting up is Lux and Lux starts up fine with the device. I've tried uninstalling and re-installing Dashclock and Lightflow, but no success.

This morning was the day I rooted my device. I unlocked, which wiped all data, installed TWRP and then installed root. After all that was finished I re-installed all my apps and started getting all my apps configured again.

Is this slowdown related to root opening up new locations such as data?

Is there anything can speed this up? It's strange that Lux starts up properly while the other two do not.

I'm going to try searching some more and looking into it, but thus far I've not found anything. Since I can't find much, it seems like this isn't a common issue with either application.

I'm using a Nexus 5.
 
Aerowinder
Old
#2  
Recognized Contributor
Thanks Meter 1031
Posts: 2,752
Join Date: Aug 2012
Quote:
Originally Posted by alamarco View Post
I have two applications that are slow to start after a reboot. They are Dashclock and Lightflow.

With regards to Dashclock, as soon as my device has reboot it displays nothing on the lockscreen for roughly a minute. I can unlock the device, use it, lock it and still nothing until it finally loads.

Same issue with Lightflow. My device will boot up and I won't get the notification that it is running until roughly a minute in.

The only other app I have starting up is Lux and Lux starts up fine with the device. I've tried uninstalling and re-installing Dashclock and Lightflow, but no success.

This morning was the day I rooted my device. I unlocked, which wiped all data, installed TWRP and then installed root. After all that was finished I re-installed all my apps and started getting all my apps configured again.

Is this slowdown related to root opening up new locations such as data?

Is there anything can speed this up? It's strange that Lux starts up properly while the other two do not.

I'm going to try searching some more and looking into it, but thus far I've not found anything. Since I can't find much, it seems like this isn't a common issue with either application.

I'm using a Nexus 5.
Are you on ART?
 

Hammerhead Firmware: Google
USB Drivers: Google
ADB+ADB Drivers: 19.0.1 (API 19) + Koush's Universal ADB Drivers v6
Recovery: TWRP | Stock KOT49H zip
Superuser: Chainfire | Mirror
 
alamarco
Old
#3  
alamarco's Avatar
Member - OP
Thanks Meter 19
Posts: 55
Join Date: Jan 2013
Quote:
Originally Posted by Aerowinder View Post
Are you on ART?
No, I'm on dalvik. Haven't touched ART at all.

Some more information, it seems this isn't related to Dashclock or Lightflow. The default lockscreen will show the clock on reboot, but the date and alarm underneath don't show up for roughly a minute.

Are there logs anywhere that could help pinpoint the delay?
 
bblzd
Old
#4  
Senior Member
Thanks Meter 178
Posts: 835
Join Date: Nov 2013
Location: Toronto
I've noticed the same thing with dashclock. Stock dalvik.

Sent from my Nexus 5 using Tapatalk
W32
 
rootSU
Old
#5  
rootSU's Avatar
Senior Member
Thanks Meter 7515
Posts: 18,124
Join Date: Aug 2010
Location: Oxenhope, West Yorkshire, UK
Loads of Apps have to start up. Its common for some to be delayed. Further more, many will have dependencies on other system processes that need to start up first.

Its normal and there's not a lot to be done about it

-----------------------
Sent via tapatalk.

I do NOT reply to support queries over PM. Please keep support queries to the Q&A section, so that others may benefit
Always read the OP's of a thread and the last 2 pages before asking questions, unless there has been an update - in which case, read the last 5 pages!

nexus 5 | SlimKat | ElementalX kernel | Philz Touch Recovery

I do NOT reply to support queries over PM.
The Following User Says Thank You to rootSU For This Useful Post: [ Click to Expand ]
 
alamarco
Old
#6  
alamarco's Avatar
Member - OP
Thanks Meter 19
Posts: 55
Join Date: Jan 2013
Quote:
Originally Posted by rootSU View Post
Loads of Apps have to start up. Its common for some to be delayed. Further more, many will have dependencies on other system processes that need to start up first.

Its normal and there's not a lot to be done about it
That's understandable. I just found it weird that it behaved differently from non-root to root. Especially with Dashclock since you're greeted with nothing except for the lock pattern upon boot.
 
Wergin
Old
#7  
Member
Thanks Meter 6
Posts: 63
Join Date: Jan 2014
May be this coz of any type of virus In application.
Or in Your Phone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


TRENDING IN THEMER...