Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,736,222 Members 44,813 Now Online
XDA Developers Android and Mobile Development Forum

Strange problems with Mobile Data and also with landscape...what can i do?

Tip us?
 
SedyBenoitPeace
Old
#1  
Senior Member - OP
Thanks Meter 85
Posts: 534
Join Date: Sep 2012
Default Strange problems with Mobile Data and also with landscape...what can i do?

Hi guys,
i write because i don't know what to do.
I have two strange problems on my Nexus 5, the first (less important) is that when i put the phone in landscape it starts to lag, but after a few seconds it works fine...this problem is less important because a reboot ever fix the problem...but what can be the cause?
The second problem that is bad and it is that i have issues with my mobile data...when i tried to use internet it is really slow and it doesn't work fine...in first place i thought to some network problems but people with Nexus 5 and also other phones told me that they haven't any problem with the same carrier.
Then i clean flash a new rom (Carbon Rom) and i noticed that the problem was gone..however after some strange reboot in calls i decided to revert to stock rom (again with clean flash) and the problem with network is here again! Is a baseband (modem) issue? Maybe the Carbon Rom uses a different baseband?
I tried also to disable Xposed (that i use on stock rom and that there isn't in Carbon) but the problem is still here!
Of course i installed the same apps on Carbon and on Stock then i was in the same conditions. I used franco kernel (both on stock and Carbon) and changing kernel is the unique thing that i didn't make but i think it's useless!
What are your advices? Thanks in advance!
 
OuncE718
Old
#2  
OuncE718's Avatar
Senior Member
Thanks Meter 302
Posts: 1,993
Join Date: Feb 2010
Location: DC by way of BK
Quote:
Originally Posted by SedyBenoitPeace View Post
Hi guys,
i write because i don't know what to do.
I have two strange problems on my Nexus 5, the first (less important) is that when i put the phone in landscape it starts to lag, but after a few seconds it works fine...this problem is less important because a reboot ever fix the problem...but what can be the cause?
The second problem that is bad and it is that i have issues with my mobile data...when i tried to use internet it is really slow and it doesn't work fine...in first place i thought to some network problems but people with Nexus 5 and also other phones told me that they haven't any problem with the same carrier.
Then i clean flash a new rom (Carbon Rom) and i noticed that the problem was gone..however after some strange reboot in calls i decided to revert to stock rom (again with clean flash) and the problem with network is here again! Is a baseband (modem) issue? Maybe the Carbon Rom uses a different baseband?
I tried also to disable Xposed (that i use on stock rom and that there isn't in Carbon) but the problem is still here!
Of course i installed the same apps on Carbon and on Stock then i was in the same conditions. I used franco kernel (both on stock and Carbon) and changing kernel is the unique thing that i didn't make but i think it's useless!
What are your advices? Thanks in advance!
I'm on stock and have only used the stock ROM. I've been facing the data issue for a while now. Its annoying and Google supposedly know about it and surprisingly still no fix.

neXus 5
 
SedyBenoitPeace
Old
#3  
Senior Member - OP
Thanks Meter 85
Posts: 534
Join Date: Sep 2012
Quote:
Originally Posted by OuncE718 View Post
I'm on stock and have only used the stock ROM. I've been facing the data issue for a while now. Its annoying and Google supposedly know about it and surprisingly still no fix.

neXus 5
Well thanks for answer! It's nice to see that i'm not the only one! However (at least in my case) is really strange...because i have friends with the same configuration (Nexus 5 and same carrier) and all work fine! But it's also strange that if i try another rom and i leave in the same condition of the stock the custom rom work while the stock not!
When i will come home tonight i will try to flash another modem...maybe is this the problem!
 
SteveMurphy
Old
#4  
SteveMurphy's Avatar
Recognized Contributor
Thanks Meter 2109
Posts: 1,214
Join Date: Apr 2012
Location: Atlanta
Quote:
Hi guys,
i write because i don't know what to do.
I have two strange problems on my Nexus 5, the first (less important) is that when i put the phone in landscape it starts to lag, but after a few seconds it works fine...this problem is less important because a reboot ever fix the problem...but what can be the cause?
No clue, never heard of this...

Quote:
The second problem that is bad and it is that i have issues with my mobile data...when i tried to use internet it is really slow and it doesn't work fine...in first place i thought to some network problems but people with Nexus 5 and also other phones told me that they haven't any problem with the same carrier.
Then i clean flash a new rom (Carbon Rom) and i noticed that the problem was gone..however after some strange reboot in calls i decided to revert to stock rom (again with clean flash) and the problem with network is here again! Is a baseband (modem) issue? Maybe the Carbon Rom uses a different baseband?
I tried also to disable Xposed (that i use on stock rom and that there isn't in Carbon) but the problem is still here!
Of course i installed the same apps on Carbon and on Stock then i was in the same conditions. I used franco kernel (both on stock and Carbon) and changing kernel is the unique thing that i didn't make but i think it's useless!
What are your advices? Thanks in advance!
Changing your modem will have an effect on your reception, not necessarily your speeds. That's usually determined by your carrier - you might want to make sure you're using the correct APN they specify. You can get them on their website. Also it could be the sim card you're using, whether or not it's LTE-compatible, or it could be the area you're in that's causing your speed troubles trouble.

As you can see, there's really no one way to fi things like this... you sort of have to troubleshoot it yourself, unfortunately.

Regarding Carbon rom, it won't change your modem - that's something you'll have to manually flash.
 
SedyBenoitPeace
Old
#5  
Senior Member - OP
Thanks Meter 85
Posts: 534
Join Date: Sep 2012
Quote:
Originally Posted by SteveMurphy View Post
No clue, never heard of this...



Changing your modem will have an effect on your reception, not necessarily your speeds. That's usually determined by your carrier - you might want to make sure you're using the correct APN they specify. You can get them on their website. Also it could be the sim card you're using, whether or not it's LTE-compatible, or it could be the area you're in that's causing your speed troubles trouble.

As you can see, there's really no one way to fi things like this... you sort of have to troubleshoot it yourself, unfortunately.

Regarding Carbon rom, it won't change your modem - that's something you'll have to manually flash.
First of all thanks for answer! Well is not necessarily slow.. It's like a connection drop.. And like you can see is not a problem in my area with my carrier but something that only I have.. There is the lte in my area but I haven't a plan with lte connection then I set my phone in a way that he didn't search for lte! I will try the modem and if it won't work I will switch on a custom rom.. The strange thing is also that with carbon I haven't any trouble but with stock yes..

Inviato dal mio Nexus 5 utilizzando Tapatalk
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes