Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,893 Members 43,081 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Switching Carriers

Tip us?
 
Crimson Ghoul
Old
#1  
Senior Member - OP
Thanks Meter 10
Posts: 122
Join Date: Nov 2011
Location: Houston
Default [Q] Switching Carriers

I have an odd problem. I got my Nexus 5 on launch week and had been using it on At&t for the first month. In December I decided to try switching to Metro PCS to get unlimited LTE. For some reason I couldn't get any signal. I would get signal for about a half hour once a week. I gave up on that and stayed on ATT. In January, I tried doing the T-Mobile $30 prepaid with 100 min + unl text/web but I couldn't get signal either. I did full wipes each time but I seem to only be able to get any service with ATT now. Has anyone tried and successfully switched carriers with the same nexus or is it just mine that's acting up?
 
OuncE718
Old
#2  
OuncE718's Avatar
Senior Member
Thanks Meter 308
Posts: 2,007
Join Date: Feb 2010
Location: DC by way of BK
Quote:
Originally Posted by Crimson Ghoul View Post
I have an odd problem. I got my Nexus 5 on launch week and had been using it on At&t for the first month. In December I decided to try switching to Metro PCS to get unlimited LTE. For some reason I couldn't get any signal. I would get signal for about a half hour once a week. I gave up on that and stayed on ATT. In January, I tried doing the T-Mobile $30 prepaid with 100 min + unl text/web but I couldn't get signal either. I did full wipes each time but I seem to only be able to get any service with ATT now. Has anyone tried and successfully switched carriers with the same nexus or is it just mine that's acting up?
I'm willing to bet 1 million dollars that the issue is because you forgot to set the APN to work for the carriers you mentioned. Every time you switch a different carrier you must manually put in the APN setting for the specific carrier for data and MMS to work.

sent from my neXus 5
 
aooga
Old
#3  
aooga's Avatar
Senior Member
Thanks Meter 857
Posts: 2,912
Join Date: Feb 2011
Location: California
Quote:
Originally Posted by Crimson Ghoul View Post
I have an odd problem. I got my Nexus 5 on launch week and had been using it on At&t for the first month. In December I decided to try switching to Metro PCS to get unlimited LTE. For some reason I couldn't get any signal. I would get signal for about a half hour once a week. I gave up on that and stayed on ATT. In January, I tried doing the T-Mobile $30 prepaid with 100 min + unl text/web but I couldn't get signal either. I did full wipes each time but I seem to only be able to get any service with ATT now. Has anyone tried and successfully switched carriers with the same nexus or is it just mine that's acting up?
Quote:
Originally Posted by OuncE718 View Post
I'm willing to bet 1 million dollars that the issue is because you forgot to set the APN to work for the carriers you mentioned. Every time you switch a different carrier you must manually put in the APN setting for the specific carrier for data and MMS to work.

sent from my neXus 5
This.

And Metro PCS and Tmobile are pretty much the same thing. If there is a problem with the service in your area, it's going to happen with both carriers.

To answer your question at the end, I have put in an ATT sim just to try it out and it worked fine.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes