FORUMS

[Q] USB Problem (searched everywhere)

245 posts
Thanks Meter: 30
 
By hhamzah49, Senior Member on 28th April 2014, 10:22 PM
Post Reply Subscribe to Thread Email Thread
7th March 2015, 03:37 PM |#21  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by CitizenLee

That, and the fact it works on your old laptop tells me it's most likely a problem with the USB ports or controller on your PC. Do you have your motherboard disk? If so try reinstalling the drivers. Check USB settings in BIOS too.

I have the same problem and it didnt fix it when connected to the usb 3.0 port
 
 
16th August 2015, 01:23 AM |#22  
Senior Member
Thanks Meter: 46
 
More
I have the same problem.... Does anyone know a solution (besides plugging it into a different USB Port or plugging it into a different USB Port?)
16th August 2015, 05:29 AM |#23  
Senior Member
Flag Chengdu
Thanks Meter: 162
 
More
Download the proper drivers, uninstall all drivers connected to your device, make sure device is not connected, restart pc, disconnect internet (Windows loves to force drivers on you), connect device and point it to correct drivers.

Something is up with your pc, not your phone.

Another option is to connect the devices over a network, wifi or bluetooth, and transfer things that way. It is best however, to get your machine to function how you want. It is quite possible if it was working and is not now that something you installed on your pc, a program or an update, broke the driver.
16th August 2015, 10:19 AM |#24  
Ben36's Avatar
Senior Member
Thanks Meter: 2,814
 
More
I found 2 things. On Windows 8.1 it suddenly decided to show up as an acer device for some reason. And secondly my lenovo laptop wouldn't recognise anything plugged into the right side of it. After trying all sorts i simply factory reset my laptop back to Windows 8 and turned off updates. Now everything works fine again. It was windows 8.1 that basically screwed everything up

Sent from my Nexus 5 using Tapatalk
16th August 2015, 03:10 PM |#25  
efrant's Avatar
Moderator Committee / Senior Moderator
Flag Montreal
Thanks Meter: 9,294
 
Donate to Me
More
The Google USB driver (found here: http://developer.android.com/sdk/win-usb.html works fine in Windows Vista, Windows 7, Windows 8, Windows 8.1 and Windows 10.

When installing the driver, never click the "search automatically for driver" (or whatever it's called) option. You need to click the second option, i.e., "browse my computer for driver". Then you need to click on "let me pick from a list of drivers. Then you must click the "Have disk" button, and then browse to where you downloaded/extracted the driver.

If you don't follow those steps, the proper driver may not install.

Sent from my Nexus 5 using Tapatalk
16th September 2015, 05:05 AM |#26  
Junior Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by slickromeo

I have the same problem.... Does anyone know a solution (besides plugging it into a different USB Port or plugging it into a different USB Port?)

did you try plugging it into a different USB port?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes