FORUMS

[Q] Wi-Fi always consuming battery at idle

425 posts
Thanks Meter: 158
 
By BirchBarlow, Senior Member on 16th January 2014, 01:45 AM
Post Reply Subscribe to Thread Email Thread
I've noticed that despite setting "Keep Wi-Fi on during sleep" to "only when plugged in" and disabling "scanning always available" Wi-Fi continues to deplete the battery at idle. According to the details in the battery stats, the Wi-Fi never turns off at idle (the Wi-Fi is shown as being on the entire time the phone is unplugged). I've found the only way to stop the Wi-Fi from depleting the battery is to disable it entirely. Has anyone else experienced this? Does this have anything to do with the kernel I'm using? Is it possibly a bug in Franco's kernel? Does this vary with the stock kernel or other custom kernels? It's not a major problem, but I'd just like to know why Wi-Fi is using up juice when it's supposedly turned off. Thanks.
 
 
16th January 2014, 04:27 AM |#2  
Recognized Contributor
Thanks Meter: 1,323
 
More
Quote:
Originally Posted by BirchBarlow

I've noticed that despite setting "Keep Wi-Fi on during sleep" to "only when plugged in" and disabling "scanning always available" Wi-Fi continues to deplete the battery at idle. According to the details in the battery stats, the Wi-Fi never turns off at idle (the Wi-Fi is shown as being on the entire time the phone is unplugged). I've found the only way to stop the Wi-Fi from depleting the battery is to disable it entirely. Has anyone else experienced this? Does this have anything to do with the kernel I'm using? Is it possibly a bug in Franco's kernel? Does this vary with the stock kernel or other custom kernels? It's not a major problem, but I'd just like to know why Wi-Fi is using up juice when it's supposedly turned off. Thanks.

It's a 4.4 deal. Pretty certain it's intentional on Google's part.
16th January 2014, 06:49 AM |#3  
Senior Member
Flag Toronto
Thanks Meter: 448
 
More
The setting worked for me. Whenever the screen was off it would switch to my data connection instead. This turns out to use 3x as much battery while idle then WiFi did in my case.

You could disable background data which wouldn't use WiFi or data but also leave your phone unconnected.
Post Reply Subscribe to Thread

Tags
battery, idle, kernel, wi-fi
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes