Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,729,194 Members 41,503 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Wifi Drop

Tip us?
 
krunal1981
Old
#1  
krunal1981's Avatar
Senior Member - OP
Thanks Meter 14
Posts: 156
Join Date: Nov 2009
Location: Bangalore
Default [Q] Wifi Drop

I have a rooted Nexus5 which aint running any custom rom. I have noticed that my wifi drops . the icon shows active on the status bar but there is no data transfer.
i thought it could be one of the xposed modules which might be interfering so i unrooted my phone and put it back to stock. The wifi signals were fine for a day or so and i am now facing the same problem again.

I downloaded the Wifi Analyser app from the play store to check if there is any interference from other routers in the vicinity. I have changed the channels multiple times but to no avail. At the same time my laptop & desktop connects fine to the router.

I am currently running stock 4.4.2 build # KOT49H
Samsung Galaxy S4 i9505 - Rooted
 
Mr hOaX
Old
#2  
Mr hOaX's Avatar
Senior Member
Thanks Meter 794
Posts: 410
Join Date: Jan 2014
Quote:
Originally Posted by krunal1981 View Post
I have a rooted Nexus5 which aint running any custom rom. I have noticed that my wifi drops . the icon shows active on the status bar but there is no data transfer.
i thought it could be one of the xposed modules which might be interfering so i unrooted my phone and put it back to stock. The wifi signals were fine for a day or so and i am now facing the same problem again.

I downloaded the Wifi Analyser app from the play store to check if there is any interference from other routers in the vicinity. I have changed the channels multiple times but to no avail. At the same time my laptop & desktop connects fine to the router.

I am currently running stock 4.4.2 build # KOT49H
Which kernel you are using?


Sent from my Nexus 5 using Tapatalk

Hit Button If I Have Helped You / If You Like This Post

 
3DSammy
Old
#3  
Senior Member
Thanks Meter 301
Posts: 674
Join Date: May 2011
Location: Toronto
Quote:
Originally Posted by krunal1981 View Post
I have a rooted Nexus5 which aint running any custom rom. I have noticed that my wifi drops . the icon shows active on the status bar but there is no data transfer.
i thought it could be one of the xposed modules which might be interfering so i unrooted my phone and put it back to stock. The wifi signals were fine for a day or so and i am now facing the same problem again.

I downloaded the Wifi Analyser app from the play store to check if there is any interference from other routers in the vicinity. I have changed the channels multiple times but to no avail. At the same time my laptop & desktop connects fine to the router.

I am currently running stock 4.4.2 build # KOT49H
Try an app called "Root- Push Notifications Fixer". There are two versions one that requires a rooted device and one that does not I use the rooted one and off hand cannot remember the difference. Below is the playstore link:
https://play.google.com/store/apps/d...ushfixer&hl=en

This app resolved a WiFi issue I was having. I originally blamed my router/device but it was neither. I use it on both my Nexus 5 and 10. Read the app description for the issue it addresses.

Good luck.

Sent from my Nexus 10 using XDA Premium HD app
Google Nexus 5 & 10: [4.4.4] rooted Stock, Franco kernel (on N5, on N10), TWRP, Xposed, GravityBox, SuperSU Pro and ViPER4Android Audio Effects FX
The Following User Says Thank You to 3DSammy For This Useful Post: [ Click to Expand ]
 
krunal1981
Old
#4  
krunal1981's Avatar
Senior Member - OP
Thanks Meter 14
Posts: 156
Join Date: Nov 2009
Location: Bangalore
Stock kernel . attached the screenshot .

Sent from my Nexus 5 using XDA Premium 4 mobile app
Attached Thumbnails
Click image for larger version

Name:	1393087335324.jpg
Views:	75
Size:	38.6 KB
ID:	2594389  
Samsung Galaxy S4 i9505 - Rooted
 
krunal1981
Old
#5  
krunal1981's Avatar
Senior Member - OP
Thanks Meter 14
Posts: 156
Join Date: Nov 2009
Location: Bangalore
Tried the app but to no avail

Sent from my Nexus 5 using XDA Premium 4 mobile app
Samsung Galaxy S4 i9505 - Rooted
 
colinmcg71
Old
#6  
colinmcg71's Avatar
Junior Member
Thanks Meter 9
Posts: 5
Join Date: Jan 2014
Location: Perth
I had something similar on my Nexus 5. The wifi speed would drop dramatically at random and it looked like web pages had stopped loading. My connection is 25Mb but the N5 would drop to 1-2Mb. I'd then have to turn wifi off and on to get the speed back up.

After searching around for the same issue a few people suggested turning off mobile data while using wifi. After doing this the speed has never dropped. I've since set up a Tasker profile to turn mobile data off when connected to wifi and back on when wifi is out of range/off.

Might be worth a try.
The Following User Says Thank You to colinmcg71 For This Useful Post: [ Click to Expand ]
 
krunal1981
Old
#7  
krunal1981's Avatar
Senior Member - OP
Thanks Meter 14
Posts: 156
Join Date: Nov 2009
Location: Bangalore
Its helping mate . will try it for a day or two to see how it works .

Sent from my Nexus 5 using XDA Premium 4 mobile app
Samsung Galaxy S4 i9505 - Rooted
The Following User Says Thank You to krunal1981 For This Useful Post: [ Click to Expand ]
 
nitramus
Old
#8  
Senior Member
Thanks Meter 5
Posts: 104
Join Date: Jan 2013
Me, I've tried everything and nothing helped at all. App Wi-Fi Analyzer tells me no signal. Tried a few kernels also. Waiting for rc of cyanogenmod to see if anything will change.

Sent from my Nexus 5 using xda app-developers app
 
krunal1981
Old
#9  
krunal1981's Avatar
Senior Member - OP
Thanks Meter 14
Posts: 156
Join Date: Nov 2009
Location: Bangalore
Guess I spoke a bit too soon . it worked fine for couple of hours and now I am back with no data transfer while on WiFi .

Sent from my Nexus 5 using XDA Premium 4 mobile app
Samsung Galaxy S4 i9505 - Rooted
 
krunal1981
Old
#10  
krunal1981's Avatar
Senior Member - OP
Thanks Meter 14
Posts: 156
Join Date: Nov 2009
Location: Bangalore
Quote:
Originally Posted by krunal1981 View Post
Guess I spoke a bit too soon . it worked fine for couple of hours and now I am back with no data transfer while on WiFi .

Sent from my Nexus 5 using XDA Premium 4 mobile app
guys , looks like i have finally sorted the problem. I called my ISP and he suggested that it could be a looping issue with the router. He advised a hard reset which i have done now. i can now connect to wifi with my phones
Samsung Galaxy S4 i9505 - Rooted

The Following 2 Users Say Thank You to krunal1981 For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes