Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,732,970 Members 49,188 Now Online
XDA Developers Android and Mobile Development Forum

Help me understand bootanimations

Tip us?
 
Grorbabrag
Old
(Last edited by Grorbabrag; 24th April 2014 at 04:54 PM.)
#1  
Grorbabrag's Avatar
Member - OP
Thanks Meter 8
Posts: 46
Join Date: Nov 2010
Default Help me understand bootanimations

Hi,

I'm trying to get a bootanimation to work. DL here: https://mega.co.nz/#!isQEkKoS!2Dyfuf...Kfkdud4WNMaY90
It is originally created by ansebovi using my upscaled version of this .gif, however it stops around the 85th frame and freezes the phone completely.
In order to boot the phone again, I have to mount /system/ through TWRP and delete the bootanimation.zip file using the file manager of TWRP.

I've read through this thread over on droidforums regarding how to create a bootanimation and modified the desc.txt accordingly. I've also tried the troubleshooting steps described in the same thread.

Now I'm looking for anyone well versed in the art of bootanimations to help me understand and fix this problem I have on my hands.

Thank you in advance!

EDIT: Upload to the forum crapped out thrice in a row now. Mega link added instead.
 
*system error*
Old
#2  
*system error*'s Avatar
Senior Member
Thanks Meter 55
Posts: 127
Join Date: Apr 2012
Location: Pensacola, FL
Not sure about your freezing problem but you can try this
Boot Animation Factory http://forum.xda-developers.com/show....php?t=1678540

or use Rom Toolbox in the playstore interface tab \ Bootanimations

Effective and easy.
 
Grorbabrag
Old
#3  
Grorbabrag's Avatar
Member - OP
Thanks Meter 8
Posts: 46
Join Date: Nov 2010
Quote:
Originally Posted by *system error* View Post
Not sure about your freezing problem but you can try this
Boot Animation Factory http://forum.xda-developers.com/show....php?t=1678540

or use Rom Toolbox in the playstore interface tab \ Bootanimations

Effective and easy.

Boot Animation Factory still produces that freezing problem.
Have not yet tried the Rom Toolbox method though.
 
*system error*
Old
#4  
*system error*'s Avatar
Senior Member
Thanks Meter 55
Posts: 127
Join Date: Apr 2012
Location: Pensacola, FL
Your Boot Ani on mega works fine on my phone. I get 3 loops bump and into the OS. Are you setting permissions correctly? rw-r-r
 
Grorbabrag
Old
#5  
Grorbabrag's Avatar
Member - OP
Thanks Meter 8
Posts: 46
Join Date: Nov 2010
Quote:
Originally Posted by *system error* View Post
Your Boot Ani on mega works fine on my phone. I get 3 loops bump and into the OS. Are you setting permissions correctly? rw-r-r
Yes. Where did you place yours? data/local/ or /system/media/ ?
Could it also have something to do with kernel / ROMs?
 
*system error*
Old
#6  
*system error*'s Avatar
Senior Member
Thanks Meter 55
Posts: 127
Join Date: Apr 2012
Location: Pensacola, FL
System media

Sent from my Nexus 5 using xda app-developers app
 
Grorbabrag
Old
(Last edited by Grorbabrag; 25th April 2014 at 07:29 AM.)
#7  
Grorbabrag's Avatar
Member - OP
Thanks Meter 8
Posts: 46
Join Date: Nov 2010
Quote:
Originally Posted by *system error* View Post
System media

Sent from my Nexus 5 using xda app-developers app
Weird,I placed it in the same place, with rw- r-- r-- permissions and all..
Maybe the difference really is in the kernel/ROM...
I use PA Beta 4 and ElemnetalX 0.36. I suppose its probably more kernel related if at all..
Which kernel so you use?
 
*system error*
Old
#8  
*system error*'s Avatar
Senior Member
Thanks Meter 55
Posts: 127
Join Date: Apr 2012
Location: Pensacola, FL
Im currently beanstalk w/ uber. Impatiently waiting for googles upgrade. Your probably right, however I've never had issues with boot animations unless on a stock samsung kernel.
Anyone out there have issues with elemental and pushing bootanimations?

Sent from my Nexus 5 using xda app-developers app

---------- Post added at 12:05 PM ---------- Previous post was at 12:03 PM ----------

It is a really cool bootanimation. For giggles have you tried any other bootanis?

Sent from my Nexus 5 using xda app-developers app
 
Grorbabrag
Old
(Last edited by Grorbabrag; 25th April 2014 at 01:18 PM.) Reason: Tried another bootanimation
#9  
Grorbabrag's Avatar
Member - OP
Thanks Meter 8
Posts: 46
Join Date: Nov 2010
Quote:
Originally Posted by *system error* View Post
Im currently beanstalk w/ uber. Impatiently waiting for googles upgrade. Your probably right, however I've never had issues with boot animations unless on a stock samsung kernel.
Anyone out there have issues with elemental and pushing bootanimations?

Sent from my Nexus 5 using xda app-developers app

---------- Post added at 12:05 PM ---------- Previous post was at 12:03 PM ----------

It is a really cool bootanimation. For giggles have you tried any other bootanis?

Sent from my Nexus 5 using xda app-developers app
I have not, that might be worth looking into. Credit for the .gif goes to /r/loadingicon over on reddit.

---------- Post added at 02:17 PM ---------- Previous post was at 01:59 PM ----------
I tried it with this animation and it booted perfectly, so I suppose that it's not purely kernel related, must be some weird interaction between the ElementalX kernel and my bootanim...

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Rir Yourself Charging Annoyances with No Wake on Charge Xposed Module

Almost every OEM has skinned and otherwise modifiedAndroid to suit its … more

Run, Jump, and Shoot in Tales of Ciaxia

There are certain types of games that have become paramount of the portable gaming world. As we have … more