Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,810,679 Members 41,217 Now Online
XDA Developers Android and Mobile Development Forum

[Q] CM10.1 freezing/sluggish

Tip us?
 
sitlet
Old
(Last edited by sitlet; 22nd August 2014 at 07:46 PM.)
#1  
Senior Member - OP
Thanks Meter 366
Posts: 2,905
Join Date: Mar 2008
Default [Q] CM10.1 freezing/sluggish

Hey all, I recently followed all the guides on here to update my TP. Was runningn CM9 for over a year, and needed a change. Decided on Jcsullins snapshot, cm-10.1-20131210-SNAPSHOT-VPN-tenderloin.zip, as I need bluetooth and camera to work, and also wanted low battery drain. Did a complete acme uninstall of android, repartitioned system to 600mb, and then used tptoolbox to install.

Now, the rom was very smooth through setup. However, after I started installing apps, about 30, it became very sluggish. pressing the home button I would have to wait about 10 seconds for it to actually go home. Apps would take 10 seconds to startup. Web/facebook scrolling was horribly choppy. Interesting though, if I rebooted, the tablet would run very smooth for the first few minutes. Only after that did it start to become slow.

So I decided to reflash the rom. Did a full wipe in CWM, and reinstalled. Again, tablet was running fine. I decided to only install a few apps this time, about 6, and everything seemed fine. But after a few minutes again, it got sluggish.

I'm wondering if maybe using tptoolbox messed something up? From everything I read about that rom, nobody has any problems with it being slow.

Also, I don't really want a heavily modified rom, which is why I haven't tried the Schizoid rom. I would like to stay at 10.1 for stability. I see the official CM nightlies here: http://forum.xda-developers.com/show....php?t=2290346
However, there are no download links to that rom, the link goes to the 10.2 download page. I didn't really want to get into a DM rom at this point. And it seems that bluetooth isn't working on that rom? Am I correct in saying that besides Schizoid, jcsullins 10.1 is the only 10.1 with bluetooth fully working?
 
Atari-San
Old
#2  
Atari-San's Avatar
Member
Thanks Meter 9
Posts: 46
Join Date: Jun 2013
Hum, got the same problem 1 year ago, my cm partition at the time was full, Using the TP Toolbox, try to give some space to the cm partition sacrificing some from the shared partition. There are more than 1 cm named partition, i don't remember exactly which one at the time was the faulty. Maybe it was the media partition.
Device i own :
-HP Touchpad (aka Tenderloin) : 4.4.4 Kitkat JCSullin build
-Samsung Galaxy SII LTE Skyrocket (aka Skyrocket) : Retired
 
sstar
Old
#3  
Senior Member
Thanks Meter 441
Posts: 1,254
Join Date: Apr 2012
Location: Brighton
Quote:
Originally Posted by sitlet View Post
Hey all, I recently followed all the guides on here to update my TP. Was runningn CM9 for over a year, and needed a change. Decided on Jcsullins snapshot, cm-10.1-20131210-SNAPSHOT-VPN-tenderloin.zip, as I need bluetooth and camera to work, and also wanted low battery drain. Did a complete acme uninstall of android, repartitioned system to 600mb, and then used tptoolbox to install.

Now, the rom was very smooth through setup. However, after I started installing apps, about 30, it became very sluggish. pressing the home button I would have to wait about 10 seconds for it to actually go home. Apps would take 10 seconds to startup. Web/facebook scrolling was horribly choppy. Interesting though, if I rebooted, the tablet would run very smooth for the first few minutes. Only after that did it start to become slow.

So I decided to reflash the rom. Did a full wipe in CWM, and reinstalled. Again, tablet was running fine. I decided to only install a few apps this time, about 6, and everything seemed fine. But after a few minutes again, it got sluggish.

I'm wondering if maybe using tptoolbox messed something up? From everything I read about that rom, nobody has any problems with it being slow.

Also, I don't really want a heavily modified rom, which is why I haven't tried the Schizoid rom. I would like to stay at 10.1 for stability. I see the official CM nightlies here: http://forum.xda-developers.com/show....php?t=2290346
However, there are no download links to that rom, the link goes to the 10.2 download page. I didn't really want to get into a DM rom at this point. And it seems that bluetooth isn't working on that rom? Am I correct in saying that besides Schizoid, jcsullins 10.1 is the only 10.1 with bluetooth fully working?
Quote:
Originally Posted by Atari-San View Post
Hum, got the same problem 1 year ago, my cm partition at the time was full, Using the TP Toolbox, try to give some space to the cm partition sacrificing some from the shared partition. There are more than 1 cm named partition, i don't remember exactly which one at the time was the faulty. Maybe it was the media partition.
You can check the size of your partitions by typing "df" without quotes into terminal emulator.
Hope this helps.
 
sitlet
Old
#4  
Senior Member - OP
Thanks Meter 366
Posts: 2,905
Join Date: Mar 2008
Thanks for the suggestions. I checked the partitions, and they are all good. I ended up reflashing a third time, and I've been running it for two days, and it's been fine 90% of the time. A few slow downs, but nothing like before.

However I do have another problem, and I don't know if it's rom related or not. I have an HP slim bluetooth keyboard that paired successfully with the tablet. Works perfectly, except if I leave the tablet unattended for about 15 minutes or so, it doesn't work. I'm fairly sure the keyboard itself is going to sleep. However, when I wake it and the tablet up, the tablet freezes completely. Tonight it even rebooted itself twice. Once was on it's own after I tried to wake the keyboard up by pressing a few buttons. The other I turned the keyboard off and back on, and when it was connected the tablet rebooted.
 
Atari-San
Old
#5  
Atari-San's Avatar
Member
Thanks Meter 9
Posts: 46
Join Date: Jun 2013
Seem related to a rom problem with drivers support for bluetooth accessory. If it was working before with the same roms, try to reflash it, otherwise, try another roms or early/newly build.
Device i own :
-HP Touchpad (aka Tenderloin) : 4.4.4 Kitkat JCSullin build
-Samsung Galaxy SII LTE Skyrocket (aka Skyrocket) : Retired
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes