Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,810,194 Members 52,069 Now Online
XDA Developers Android and Mobile Development Forum

[BUG] WiFi disconnects randomly

Tip us?
 
salar2k
Old
(Last edited by salar2k; 30th August 2014 at 05:56 PM.)
#1  
Junior Member - OP
Thanks Meter 2
Posts: 4
Join Date: Dec 2013
Default [BUG] WiFi disconnects randomly

My WiFi keeps disconnecting every now and then randomly and I have tried many things and still no luck.

I have:
N.O.P.E kernel 2.6 on 750MHz OC
MiniCM10 V8 clean flash

Here is what happens, After I connect to the router the phone pings correctly immediately after I start using internet (with any app) the connection drops after a few seconds.

The weird part that I have screenshoted with WiFi analyzer:
One screenshot is before I connect to the SLR-DSL2 and the other one is after I have connected to the router. Second one shows no signal change which is not normal of course.
And the third screen shot shows ping responses from my phone, before and after connection.

I have tried Wifi Keep Alive but it just *sometimes* reconnects the broken connection. (Option 3 & 4)
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-08-30-20-38-42.png
Views:	32
Size:	107.4 KB
ID:	2918344   Click image for larger version

Name:	Screenshot_2014-08-30-20-40-11.png
Views:	29
Size:	104.1 KB
ID:	2918345   Click image for larger version

Name:	Ping.png
Views:	31
Size:	18.2 KB
ID:	2918346  
 
warrior1208
Old
(Last edited by warrior1208; 30th August 2014 at 07:07 PM.)
#2  
warrior1208's Avatar
Senior Member
Thanks Meter 575
Posts: 337
Join Date: Sep 2013
Location: Delhi
Quote:
Originally Posted by salar2k View Post
My WiFi keeps disconnecting every now and then randomly and I have tried many things and still no luck.

I have:
N.O.P.E kernel 2.6 on 750MHz OC
MiniCM10 V8 clean flash

Here is what happens, After I connect to the router the phone pings correctly immediately after I start using internet (with any app) the connection drops after a few seconds.

The weird part that I have screenshoted with WiFi analyzer:
One screenshot is before I connect to the SLR-DSL2 and the other one is after I have connected to the router. Second one shows no signal change which is not normal of course.
And the third screen shot shows ping responses from my phone, before and after connection.

I have tried Wifi Keep Alive but it just *sometimes* reconnects the broken connection. (Option 3 & 4)
WiFi keep alive>Advanced>Enable Workaround 2>WiFi on during sleep>Log on to XDA>Use the search bar integrated on the MiniCM 10 Thread>Close the browser!
Just a piece of advice my friend, please keep these Desire C forums clean... XDA Creators have made a brilliant feature> SEARCH BAR!!! Try and learn how to use it!
 
salar2k
Old
#3  
Junior Member - OP
Thanks Meter 2
Posts: 4
Join Date: Dec 2013
Quote:
Originally Posted by warrior1208 View Post
WiFi keep alive>Advanced>Enable Workaround 2>WiFi on during sleep>Log on to XDA>Use the search bar integrated on the MiniCM 10 Thread>Close the browser!
Just a piece of advice my friend, please keep these Desire C forums clean... XDA Creators have made a brilliant feature> SEARCH BAR!!! Try and learn how to use it!
Sorry to say this but I have tried it with no luck. Maybe you've prejudged because I didn't mention it!
 
salar2k
Old
#4  
Junior Member - OP
Thanks Meter 2
Posts: 4
Join Date: Dec 2013
Well after a few days of struggle and testing different ROMs and Kernels, I managed to fix the WiFi issue by restoring the Stock HTC Rom then factory reset and installing Prometheus Sense4 Kernel.

The issue was really annoying and nothing could fix it. I tried MiniCM on Nope and Prometheus with no luck. Even RevolutionMod roms on android 4 had the issue.

Anyway with my phone config is almost stable and WiFi rocks as it should be . But the UI (HTC) is not fluent as it was on Cm10
HTC Stock ROM on Prometheus Sense4 800 OC.
Thread Tools
Display Modes