Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,540 Members 38,467 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Unable to boot in recovery and fastboot.

Tip us?
 
TomWis97
Old
(Last edited by TomWis97; 21st July 2014 at 08:13 AM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 21
Join Date: Jul 2011
Default [Q] Unable to boot in recovery and fastboot.

Hello,

I have here a Desire HD which was running Ice Cold Sandwich. The ROM became unstable, so I wanted to give CM 10.1 a try. This Desire HD was been HTC Dev unlocked, but is still S-ON. So, I can't flash the boot partition from recovery. I rebooted the phone into fastboot and flashed the boot partition. (fastboot flash boot boot.img) I thought it was possible to reboot to recovery with fastboot, but it seems to be not possible. So I did "fastboot reboot". And that's where the misery started...
Although I was able to navigate through the bootloader with the volume rocker, I seem to be unable to boot the device in fastboot nor the recovery. It keeps booting ICS. However, the volume down seems only to work occasionally. Because it's not running the ICS boot.img, it's stuck in a bootloop. When the device is "booting" and I try to reboot the device using adb, I get the message that my computer is not authorised.

I do the following when attempting to boot in fastboot or recovery: (I don't really care if I get the device to boot in fastboot or recovery. I can get the device to work in fastboot or recovery.)
I make sure that the device is turned off completely by removing the battery. Then I hold the volume up (that seems to be the best working one) and after about half a second I press the power button. I hold both until the white HTC screen goes away. I also tried to let the powerbutton go at the moment that the HTC screen appears.

Quick summary:
State of the device:
HTC Dev unlocked.
Running Ice Cold Sandwich.
Recovery is 4EXT.
CM 10.1 boot.img.
Bootlooping.
Not responding when holding the volume button when booting.
Unable to connect to it using adb.

Can someone please, please help me? I'm usually not a noob, but I really f*****d it up this time.
The worst part is: it's not even mine...
 
TomWis97
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 21
Join Date: Jul 2011
I fixed it. The volume rocker seemed to be the problem. I removed the sticker under the battery cover and popped the buttons out. While holding the battery with my left thumb, using my left hand for pushing the volume down button and pushing the powerbutton with my left index finger I got it to boot to the bootloader. Yes, it was pretty awkward. I flashed the ROM from the SD card and it boots.

My problem is solved!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes