[Q] Wi-Fi won't turn on, any ideas?

37 posts
Thanks Meter: 1
By Keirnoth, Member on 26th August 2014, 08:15 PM
Post Reply Subscribe to Thread Email Thread
Hey guys.

My T-Mo G2/Desire Z is running CyanogenMod 6/Froyo 2.2. All of a sudden out of the blue the wifi just shat out on me while I was watching a Youtube video. I tried reconnectin to WiFi and it tries to turn on, but tells me it's "unable to scan for networks". I've been able to get it up for a short while by smacking the back of my phone, but I'm wondering if I'm missing anything obvious.

Did the following:
1) Pulled the battery with the phone on, waited 30 seconds, turned it back on, no go.
2) Powered off the phone, pulled the battery, waited 30 seconds, nope.
3) Grabbed a WiFi monitoring ap and noticed that the WiFi driver is unable to initialize, which probably means a hardware problem.
4) Like I said, smacking the back of my phone helped get it back for a few, but it went dead again as soon as I tried moving it.

I'm hoping this is something software related, but due to how old this phone is and how long I've had it for and how it has a tendency to get warm from long sessions of use, do you guys think the solder for the wifi antenna has gone bad? I'm a dunce and don't know how to solder, but I can only imagine the heat produced by the phone would be an issue for such a fragile solder point.

I don't really want to do a factory reset (don't have the original ROM around) - is there something I can check to make absolutely sure it's a hardware problem and not a software problem?

I love this phone too much to switch - might have to buy a used one because I don't want to take this thing apart - watched a disassembly video for it and it looked like a complete pain in the ass (and I've replaced the digitizer on my old HTC Herald).

Thanks all, your help will be much appreciated.
27th August 2014, 03:13 AM |#2  
Senior Member
Thanks Meter: 92
My son's G2 did the same thing. No more wifi. 3g still works, but not wifi.

Sent from my Nexus 7 using Tapatalk
15th November 2015, 12:10 AM |#3  
OP Member
Thanks Meter: 1
Bumping this, as I'm noticing there's a bit more activity on this forum. I've been running for over a year without Wi-Fi and I'd like to get that back. Still not sure what the problem is and nothing I've done has solved it.
Post Reply Subscribe to Thread

desire z, wifi

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes