Cyngn, OnePlus, Micromax – The Legal Battle

Recently, a battle has been waging in India over the rights to distribute the commercial … more

Lean Mean Battery Power Saving App Review

We talk a lot about battery topics here at XDA TV. We talk about everything from Power Banks to USB … more

Android 5.1 Possibly Coming February 2015

Google released Android 5.0 just over a month ago, and since then Lollipop has been trying to … more

Double Tap to Wake on the Nexus 6 Without Root

A few weeks ago, we featured an app which allowed the Nexus 6 to regain the double tap to wake … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Problems with downgrading from Evervolv Kitkat to Oxygen

OP Folrot

25th August 2014, 07:36 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Jul 2014
Hi,

I'm not content with the performance of KitKat ROMs on the desire and wanted to try an older Gingerbread ROM. I wanted to try MildWild 5 or Oxygen 2.3.2 but I'm having problems.
I was on HBoot Alpharev Jelly (250/5/182) and was running TWRP 2.7.1.0. I tried to flash the HBoot oxygen r2 alpharev, which worked fine, but then I couldn't boot into TWRP any more I just get stuck at the TWRP boot logo.

I guessed it was maybe due to system partition being too small for twrp (?) and flashed cm7r2 hboot, but that didn't help, still stuck at TWRP boot screen. After that I tried to flash 4ext v1.0.0.5 RC9 recovery, but this one boots without showing me any buttons (really strange). I can drag down the "Welcome to 4EXT Recovery Touch by madmaxx82 (...etc)"-screen so this recovery seems to work a little bit?! Useless without any buttons tho.

I'm really confused and don't want to continue as I'm apparently not as certain about what I'm doing as I thought I was.
Do I need CWM Recovery for gingerbread ROMs? Are TWRP and 4EXT not working because system partition is too small? (as I said above, I'm atm on Bravo CM7 r2 (145/5/287) from http://alpharev.nl/

What do I need to do to get older ROMs working?
26th August 2014, 12:23 AM   |  #2  
eddiehk6's Avatar
Senior Member
Flag London
Thanks Meter: 638
 
1,429 posts
Join Date:Joined: Dec 2010
More
Recovery is installed to a separate partition, not the /system partition so that's not the problem.

TWRP or 4EXT should work fine for installation of any ROM. I personally used 4EXT for older GB ROMs no issue.

All I can suggest is to redownload the 4EXT recovery.img, check the md5sum and flash using fastboot

As a last resort, backup everything (apps/contacts/SMS etc), and flash the 2.3.3 RUU to go completely stock (+stock recovery)

Then S-OFF and flash 4EXT again.
26th August 2014, 11:53 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Jul 2014
I'm very puzzled at the moment.
I thought running the 2.3.3 RUU won't get you back to S-On as alpharev hboots are protected? I also don't quite see the reason for going S-On again.

I tried flashing TWRP 2710, TWRP 2630 and 4EXT v1.0.0.5 RC9 using either fastboot or PB99IMG-method. I get no errors while flashing, but the recoveries don't work properly. TWRP always gets stuck at its boot screen and 4ext boots, but then doesn't show me any buttons. I checked the MD5 of the images before flashing every time.

My bootloader atm shows me:
AlphaRev CM7 r2
BRAVO PVT3 SHIP S-OFF
MICROP-051d
TOUCH PANEL-SYNT0101
RADIO-5.17.05.23
Aug 10 2010, 17:52:18

I was on TWRP 2710 when I changed my hboot from alpharev jelly to alpharev oxygen r2 (or now alpharev cm7 r2). This recovery has a bug which deletes the tmp directory all the time (you can't flash from this recovery unless you run "mkdir tmp" in a terminal). Could this be the reason why the recoveries now are not working any more?

I think I'll try to flash alpharev jelly and restore a nandroid (to see if a recovery would work then) before running a RUU.
26th August 2014, 12:45 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Jul 2014
Flashed alpharev jelly hboot and the recovery is working again (atm twrp 2630)

So how do I do this properly without running into the same problem again?
26th August 2014, 01:44 PM   |  #5  
Senior Member
Thanks Meter: 66
 
270 posts
Join Date:Joined: Apr 2011
More
Simply wipe everything except for the SD card of course and then flash your new hboot.

Sent from my GT-I9100 using Tapatalk
26th August 2014, 03:34 PM   |  #6  
OP Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Jul 2014
It works now.
What I did: Flash 4EXT recovery on alpharev jelly, flash manwild from recovery, wipe everything except sdcard, flash alpharev cm7r2, flash Manwild
No idea what went wrong in the first place, but everything works now and the ROM is great!
Thanks!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes