[Q] Cannot flash custom ROM, what am I doing wrong?

4 posts
Thanks Meter: 1
By ioannoukyriakos, Junior Member on 1st July 2014, 12:21 AM
Post Reply Subscribe to Thread Email Thread
I decided to use my old HTC Magic as a second phone, but I realised that 1,5 is too old. So I thought I should root it and flash a custom recovery and ROM, how difficult can it be, right?

The phone is a black Magic without the 3,5 jack. I believe it's unbranded, the splashscreen is HTC.

Info before doing anything on it:
HBOOT 1.33.0010 (SAPP 10000)
CPLD - 7

I found out that the HBOOT is a "perfected" SPL, so I followed a guide with the goldcard to flash a stock ROM with another SPL.

Info after that:
HBOOT 1.33.0009 (SAPP 10000)
CPLD - 7

I also followed the guide in this forum to root the device and flash an eng SPL. now the SPL is 1.33.2010.
Amon_RA's recovery did not work for me, the home button (for confirmation) is not working in recovery. Instead, I flashed Clockwork recovery and I was able to have full functionality in recovery mode.

Now I am trying to install a custom ROM. Most links are broken, so I went with what was available: Cyanogen 5.0.7 final with GAPPS and Cyanogen 6.1.

The problem is that both ROM's I tried will install successfully, but when I reboot the phone it will just hang on the HTC logo.

What am I missing?

Thanks in advance.
1st July 2014, 12:39 PM |#2  
OP Junior Member
Thanks Meter: 1
A lot of frustration accompanied by the fear of bricking the phone results in a great deal of stupidity...

I hadn't flashed a kernel.

Please mark this as solved.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes