Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,737,213 Members 39,738 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Vibration suddenly doesn't work

Tip us?
 
ArtificialMusik
Old
#1  
ArtificialMusik's Avatar
Senior Member - OP
Thanks Meter 74
Posts: 334
Join Date: Jul 2011
Location: Queen Creek, AZ

 
DONATE TO ME
Default [Q] Vibration suddenly doesn't work

Yesterday I noticed my Haptic feedback wasn't working. I tried ticking every setting and seeing if I could find what turned it off. Doesn't work when I receive a text, a call, or even when the alarm goes off. So I downloaded a vibrator app and it doesn't work. Suggestions? Halp?

Sent from my HTC One_M8 using Tapatalk
AT&T HTC One M8 Gunmetal 32GB:
ROM: ViperOne

Phone/TAB History:
AT&T Samsung Galaxy Note II 16GB
HP Touchpad 32GB
Apple iPhone 4 32GB Black: Dead.
Samsung Galaxy S II: Charge problem.
Apple iPad 2 32GB WiFi: Sold
Samsung Galaxy S Captivate: Sold
AT&T HTC Fuze: Unlocked, Own.
Apple iPad 32GB WiFi: Sold
Apple iPhone 3G(S) 32GB Black: Sold; Unlocked
Apple iPhone 3G 16GB Black: Traded.
 
jeffalamillo7
Old
#2  
Junior Member
Thanks Meter 4
Posts: 26
Join Date: Jan 2011
Location: Westlake Village
Quote:
Originally Posted by ArtificialMusik View Post
Yesterday I noticed my Haptic feedback wasn't working. I tried ticking every setting and seeing if I could find what turned it off. Doesn't work when I receive a text, a call, or even when the alarm goes off. So I downloaded a vibrator app and it doesn't work. Suggestions? Halp?

Sent from my HTC One_M8 using Tapatalk
+1 I've been having the same issue. Running ViperOne At&t with ElementalX.
 
ArtificialMusik
Old
#3  
ArtificialMusik's Avatar
Senior Member - OP
Thanks Meter 74
Posts: 334
Join Date: Jul 2011
Location: Queen Creek, AZ

 
DONATE TO ME
I'm on ViperOne 1.8 but stock kernel.

Sent from my HTC One_M8 using Tapatalk
AT&T HTC One M8 Gunmetal 32GB:
ROM: ViperOne

Phone/TAB History:
AT&T Samsung Galaxy Note II 16GB
HP Touchpad 32GB
Apple iPhone 4 32GB Black: Dead.
Samsung Galaxy S II: Charge problem.
Apple iPad 2 32GB WiFi: Sold
Samsung Galaxy S Captivate: Sold
AT&T HTC Fuze: Unlocked, Own.
Apple iPad 32GB WiFi: Sold
Apple iPhone 3G(S) 32GB Black: Sold; Unlocked
Apple iPhone 3G 16GB Black: Traded.
 
jeffalamillo7
Old
#4  
Junior Member
Thanks Meter 4
Posts: 26
Join Date: Jan 2011
Location: Westlake Village
Quote:
Originally Posted by ArtificialMusik View Post
I'm on ViperOne 1.8 but stock kernel.

Sent from my HTC One_M8 using Tapatalk
Hmm so it's not a kernel issue then. Even when I boot up the phone there's no vibration that usually indicates the boot up. Even in TWRP I don't get any feedback when selecting options. Faulty motor?
 
eddyctweets
Old
#5  
Member
Thanks Meter 12
Posts: 85
Join Date: Nov 2013
Do you have quiet hours turned on I've seen it keep haptic off even if its not the specified hours

Sent from my GT-N8010 using XDA Free mobile app
 
ArtificialMusik
Old
#6  
ArtificialMusik's Avatar
Senior Member - OP
Thanks Meter 74
Posts: 334
Join Date: Jul 2011
Location: Queen Creek, AZ

 
DONATE TO ME
I don't use quite hours.

Sent from my HTC One_M8 using Tapatalk
AT&T HTC One M8 Gunmetal 32GB:
ROM: ViperOne

Phone/TAB History:
AT&T Samsung Galaxy Note II 16GB
HP Touchpad 32GB
Apple iPhone 4 32GB Black: Dead.
Samsung Galaxy S II: Charge problem.
Apple iPad 2 32GB WiFi: Sold
Samsung Galaxy S Captivate: Sold
AT&T HTC Fuze: Unlocked, Own.
Apple iPad 32GB WiFi: Sold
Apple iPhone 3G(S) 32GB Black: Sold; Unlocked
Apple iPhone 3G 16GB Black: Traded.
 
eddyctweets
Old
#7  
Member
Thanks Meter 12
Posts: 85
Join Date: Nov 2013
OK but just check its not turned off in quiet hours as it can affect it even if your not using it

Sent from my GT-N8010 using XDA Free mobile app
 
ArtificialMusik
Old
#8  
ArtificialMusik's Avatar
Senior Member - OP
Thanks Meter 74
Posts: 334
Join Date: Jul 2011
Location: Queen Creek, AZ

 
DONATE TO ME
Checked it out and it's been off this whole time. Even in Recovery Mode it doesn't vibrate as normally. Will try installing a new rom today.
AT&T HTC One M8 Gunmetal 32GB:
ROM: ViperOne

Phone/TAB History:
AT&T Samsung Galaxy Note II 16GB
HP Touchpad 32GB
Apple iPhone 4 32GB Black: Dead.
Samsung Galaxy S II: Charge problem.
Apple iPad 2 32GB WiFi: Sold
Samsung Galaxy S Captivate: Sold
AT&T HTC Fuze: Unlocked, Own.
Apple iPad 32GB WiFi: Sold
Apple iPhone 3G(S) 32GB Black: Sold; Unlocked
Apple iPhone 3G 16GB Black: Traded.
 
ArtificialMusik
Old
#9  
ArtificialMusik's Avatar
Senior Member - OP
Thanks Meter 74
Posts: 334
Join Date: Jul 2011
Location: Queen Creek, AZ

 
DONATE TO ME
Quote:
Originally Posted by jeffalamillo7 View Post
Hmm so it's not a kernel issue then. Even when I boot up the phone there's no vibration that usually indicates the boot up. Even in TWRP I don't get any feedback when selecting options. Faulty motor?
How long as your issue been going on? Where did you get your device? I'm wondering if it was a production issue.
AT&T HTC One M8 Gunmetal 32GB:
ROM: ViperOne

Phone/TAB History:
AT&T Samsung Galaxy Note II 16GB
HP Touchpad 32GB
Apple iPhone 4 32GB Black: Dead.
Samsung Galaxy S II: Charge problem.
Apple iPad 2 32GB WiFi: Sold
Samsung Galaxy S Captivate: Sold
AT&T HTC Fuze: Unlocked, Own.
Apple iPad 32GB WiFi: Sold
Apple iPhone 3G(S) 32GB Black: Sold; Unlocked
Apple iPhone 3G 16GB Black: Traded.
 
jeffalamillo7
Old
#10  
Junior Member
Thanks Meter 4
Posts: 26
Join Date: Jan 2011
Location: Westlake Village
Quote:
Originally Posted by ArtificialMusik View Post
How long as your issue been going on? Where did you get your device? I'm wondering if it was a production issue.
I got my device from an At&t authorized seller about a month or so ago. The feedback occasionally does come back for a few seconds before dying off again. Very odd. I haven't tried flashing a new rom but I did a factory reset yielding no results.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes