Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,804,955 Members 52,926 Now Online
XDA Developers Android and Mobile Development Forum

Followed "All-In-One Toolkit" rooting instructions, but not rooted

Tip us?
 
Lanthanide
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Aug 2014
Question Followed "All-In-One Toolkit" rooting instructions, but not rooted

I followed all the instructions in this thread to root my HTC M8: http://forum.xda-developers.com/show...ghlight=binary

I've got the TWRP recovery installed and did the "perm root" thing, which appeared to work as the SuperSU app was in the app launcher.

Now today when I tried to install xposed framework I discovered that the root apparently doesn't work. Opening up the SuperSU application gave this following warning:
"There is no SU binary installed and SuperSU canít install it"

I googled around but didn't find anything concrete on what to do. I did find this one page that has a supposed fix in the comments, which I tried using but that hasn't done anything: http://www.theandroidsoul.com/root-new-htc-one-2014-m8/

I then thought I'd re-do the "perm root" step again, so I tried that using the all-in-one app, but now when I boot the phone up the SuperSU app doesn't show up in the app drawer at all and doesn't appear to be installed on the device at all, but the flashing step in the recovery doesn't give any errors at all.

So I'm stuck and don't know what to do now. I tried manually doing the flashing that the "perm root" step does but that hasn't given any other results either.
 
Lanthanide
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Aug 2014
Searched the forum for "supersu binary" and found this thread, which had the solution to this problem: http://forum.xda-developers.com/htc-...grade-t2852100

Quote:
EDIT: Success!
Turns out I needed to re-flash my SuperSU binary from TWRP. I re-flashed the version I had first which actually removed the SuperSU apk. I re-downloaded it from Play Store, then flashed the 2.01 update. Runs like a charm.
Thanks to everyone for the help.
This worked for me. Just went to the store and got supersu. Upon running it, it tells me to upgrade, the Normal mode didn't work but the Recovery mode did. Now after that, root checker says I'm successfully rooted and another app I has can get root permissions too.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes