Update Overload: SuperSU Heavily Updated

There are apps and apps out there. Very few can reach the level of popularity required to stay at … more

Lollipop Leak Available for the Sprint Galaxy S5

Since the Android 5.0Lollipop’s official release not too long ago, we’ve seen … more

CPU Spy Gets an Android Lollipop Makeover

At some point in the distant past, you probably heard of CPU Spy for Android by XDARetired … more

Amazon Fire TV Stick vs Chromecast – XDA TV

There is no doubt that Amazon is a huge player in many markets, and they want to be a huge … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

After OTA 2.22.1540.3 (4.4.3), Camera app crashes on Zoe and Video Camera mode

OP komugi

29th July 2014, 01:22 AM   |  #1  
OP Senior Member
Flag NYC, CT
Thanks Meter: 40
 
238 posts
Join Date:Joined: Sep 2008
More
After OTA 2.22.1540.3 (4.4.3), Camera app crashes on Zoe and Video Camera mode. I have tried disabling Xposed, and any modifcation, as well as booting into Safe mode, doesn't seem to fix it.

Is anyone else getting this issue?
29th July 2014, 01:33 AM   |  #2  
boe323's Avatar
Senior Member
Thanks Meter: 194
 
1,179 posts
Join Date:Joined: Jun 2012
Quote:
Originally Posted by komugi

After OTA 2.22.1540.3 (4.4.3), Camera app crashes on Zoe and Video Camera mode. I have tried disabling Xposed, and any modifcation, as well as booting into Safe mode, doesn't seem to fix it.

Is anyone else getting this issue?

lol ...your right ...mine doesn't even open it reboots the phone, and google camera force closes? what a pointless update lol. mines 2.22.401.3. Stupid camera upgrades ....were these even tested? now my media database is messed up, wont play the right sound I set. I thought there was something odd about this update, after the upgrade ...it only optimised a 100 apps ....it always did 359 apps before, wiping dalvik manually does the same, 100 apps, theres a storage issue aswell as the camera, and google camera don't work either, its not part of sense. Is it because we are rooted etc? Oh yes and art don't work for me either.UPDATE: Got ART to work, but not the cameras ...any camera to be exact, thought it might be supercid or because its unlocked but that wouldn't stop other camera apps would it?
Last edited by boe323; 29th July 2014 at 02:22 AM.
29th July 2014, 07:57 AM   |  #3  
Member
Singapore
Thanks Meter: 10
 
39 posts
Join Date:Joined: Mar 2013
If you have Xposed and other root system tweaking apps installed you really can't expect OTA's to go perfectly smooth, can you?
29th July 2014, 08:28 AM   |  #4  
Member
Thanks Meter: 6
 
44 posts
Join Date:Joined: Jul 2007
More
Mine is working just fine, I'm rooted but with stock recovery and no xposed.
29th July 2014, 04:03 PM   |  #5  
OP Senior Member
Flag NYC, CT
Thanks Meter: 40
 
238 posts
Join Date:Joined: Sep 2008
More
Quote:
Originally Posted by KriBKriB

If you have Xposed and other root system tweaking apps installed you really can't expect OTA's to go perfectly smooth, can you?

I restored to stock before I flashed the OTA, only after the OTA did I root/run Xposed again.
29th July 2014, 05:25 PM   |  #6  
exocetdj's Avatar
Recognized Contributor
Flag Outer Mongolia
Thanks Meter: 2,356
 
3,510 posts
Join Date:Joined: Dec 2011
Donate to Me
More
mine is working absolutley fine, even after converting my m8 to a dev edition from WWE edition. I was completeley stock before i took ota (no mods, nothing)
29th July 2014, 08:38 PM   |  #7  
OP Senior Member
Flag NYC, CT
Thanks Meter: 40
 
238 posts
Join Date:Joined: Sep 2008
More
Quote:
Originally Posted by exocetdj

mine is working absolutley fine, even after converting my m8 to a dev edition from WWE edition. I was completeley stock before i took ota (no mods, nothing)

Yeah, turns out it was an app conflict, mainly Google Now/Google Voice Search -- when you enable "Ok, Google" from any screen in the Google Now settings, it interferes with the Camera apps microphone access, sometimes it is able to terminate the process and use the microphone, but when it's not able to, it crashes.
Last edited by komugi; 29th July 2014 at 08:43 PM.
The Following User Says Thank You to komugi For This Useful Post: [ View ]
29th July 2014, 08:48 PM   |  #8  
Member
Thanks Meter: 13
 
59 posts
Join Date:Joined: Sep 2009
Quote:
Originally Posted by komugi

Yeah, turns out it was an app conflict, mainly Google Now/Google Voice Search -- when you enable "Ok, Google" from any screen in the Google Now settings, it interferes with the Camera apps microphone access, sometimes it is able to terminate the process and use the microphone, but when it's not able to, it crashes.

Thanks much. This problem was also causing my video button to require a double press. It wasn't crashing, but the first press must disable the "Ok, Google" listening, then the second press would record the video.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes