Post Reply

[Q] HTC One X - Impossible to install custom ROM

OP jeanchoquette56

29th July 2014, 02:04 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Jul 2014
Hey there!
I'm pretty new to the Android platform. I've been on iOS for many years.
I already flashed a custom firmware on a Moto G, which worked fine. (SlimKat)
I thought about doing the same thing with my HTC One X.

GSM version (Model: PJ83100)

Current device state:
*** TAMPERED ***
*** UNLOCKED ***
EVITA PVT SHIP S-ON RL
HBOOT-2.14.0000
RADIO-0.23a.32.01.29
OpenDSP-v31.1.0.45.0815
eMMC-boot
Nov 26 2012, 18:37:14:-1

Unlike the Moto G Bootloader, I'm unable to erase any partition but the cache. Example:
./fastboot erase system
erasing 'system'...
FAILED (remote: not allowed)

I am not able to boot into the OS or the recovery partition anymore, so they have probably been wiped. When I reboot the device, it's either a boot loop or it just shuts down.

I already tried to flash CWM and TWRP. Each of those were successful, at least according to the terminal... Unfortunately, same thing happens when the phone reboots.
I also tried to flash SlimKat with the "./fastboot flash zip file_name.zip" command, even if it isn't supposed to work (I believe).
In despair, I flashed the boot image from the ROM but still without result.

If anyone knows how to fix this, it would be really appreciated.
All the posts related to the issue did not help me in any ways.
Thank you!
Last edited by jeanchoquette56; 29th July 2014 at 02:10 PM.
29th July 2014, 07:11 PM   |  #2  
Senior Member
New York
Thanks Meter: 27
 
286 posts
Join Date:Joined: Jul 2010
More
Try the Forum for the One X.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes