Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,143 Members 54,532 Now Online
XDA Developers Android and Mobile Development Forum

adb device not found

Tip us?
 
RedBlackPellet
Old
(Last edited by RedBlackPellet; 28th July 2014 at 04:27 PM.)
#1  
RedBlackPellet's Avatar
Senior Member - OP
Thanks Meter 290
Posts: 249
Join Date: Mar 2013
Default adb device not found

the device is not found however I installed the drivers and I am using windows 7 I tried it with another computer and it didn't work
and it works with the recovery I want it to work to gain s-off
IF I HELPED PLEASE HIT THANKS
 
nkk71
Old
#2  
nkk71's Avatar
Recognized Contributor
Thanks Meter 2,930
Posts: 5,914
Join Date: May 2010
Location: Beirut
Quote:
Originally Posted by RedBlackPellet View Post
the device is not found however I installed the drivers and I am using windows 7 I tried it with another computer and it didn't work
and it works with the recovery I want it to work to gain s-off
check FAQ#2: http://forum.xda-developers.com/show...24&postcount=2
 
RedBlackPellet
Old
#3  
RedBlackPellet's Avatar
Senior Member - OP
Thanks Meter 290
Posts: 249
Join Date: Mar 2013
Quote:
Originally Posted by nkk71 View Post
I tried with different devices laptops and mobiles and I always get device not found and different adb sdks
IF I HELPED PLEASE HIT THANKS
 
Seanie280672
Old
(Last edited by Seanie280672; 28th July 2014 at 06:37 PM.)
#4  
Seanie280672's Avatar
Senior Member
Thanks Meter 343
Posts: 1,162
Join Date: Feb 2012
Location: Halesowen

 
DONATE TO ME
Quote:
Originally Posted by RedBlackPellet View Post
I tried with different devices laptops and mobiles and I always get device not found and different adb sdks
if your booted into a rom, do you have usb debugging enabled ?

its in system, developer options, if you cant see developer options then goto about - software information - more - and tap build number 7 times, it will count down and eventually say you are now a developer, you should now see developer options in your system menu.

when you enable usb debugging and plug your phone into the computer.....eventually.....and sometimes it takes a while, you will get a pop up on your phone saying your computer wants to connect to this device, allow or deny, I suggest you allow.

if you don't get the message, then with the phone still plugged into the computer, open developer options again and disable usb debugging, then enable it again.
 
RedBlackPellet
Old
#5  
RedBlackPellet's Avatar
Senior Member - OP
Thanks Meter 290
Posts: 249
Join Date: Mar 2013
Quote:
Originally Posted by Seanie280672 View Post
if your booted into a rom, do you have usb debugging enabled ?

its in system, developer options, if you cant see developer options then goto about - software information - more - and tap build number 7 times, it will count down and eventually say you are now a developer, you should now see developer options in your system menu.

when you enable usb debugging and plug your phone into the computer.....eventually.....and sometimes it takes a while, you will get a pop up on your phone saying your computer wants to connect to this device, allow or deny, I suggest you allow.

if you don't get the message, then with the phone still plugged into the computer, open developer options again and disable usb debugging, then enable it again.
Ofcourse i even tried different devices and cables and I always get device not found and simetimes device offline
IF I HELPED PLEASE HIT THANKS
 
Seanie280672
Old
#6  
Seanie280672's Avatar
Senior Member
Thanks Meter 343
Posts: 1,162
Join Date: Feb 2012
Location: Halesowen

 
DONATE TO ME
Quote:
Originally Posted by RedBlackPellet View Post
Ofcourse i even tried different devices and cables and I always get device not found and simetimes device offline
im at a loss, sorry I couldn't help any further, but if its doing it with different devices, it has to be a software issue, especially as you say its working in recovery and bootloader, the only thingf I picked out from your picture is it states your adb is out of date, but you say you've tried that too, all I can suggest is you try this one.

http://forum.xda-developers.com/show....php?t=2588979

also where did you get the drivers from
The Following User Says Thank You to Seanie280672 For This Useful Post: [ Click to Expand ]
 
nkk71
Old
#7  
nkk71's Avatar
Recognized Contributor
Thanks Meter 2,930
Posts: 5,914
Join Date: May 2010
Location: Beirut
Quote:
Originally Posted by RedBlackPellet View Post
and sometimes device offline
reboot PC and phone, use a USB2 port
The Following User Says Thank You to nkk71 For This Useful Post: [ Click to Expand ]
 
alray
Old
#8  
alray's Avatar
Senior Member
Thanks Meter 1,098
Posts: 2,841
Join Date: May 2012
Location: Montreal

 
DONATE TO ME
Quote:
Originally Posted by RedBlackPellet View Post
Ofcourse i even tried different devices and cables and I always get device not found and simetimes device offline
why are you using an adb shell to push the file? push the file using adb and then enter the shell to chmod the "ff" file (I suppose you are pushing firewater but your renamed the file to "ff" ?) And btw "adb devices" will not output your device ID from an adb shell.

Code:
adb devices
adb push ff /data/local/tmp
then
Code:
adb shell
su ---> to get a # prompt
chmod 775 /data/local/tmp/ff --> to give read/write/execute permission
/data/local/tmp/ff
If I've helped you, please hit the ''tanks'' button
If you want a reply, quote or mention me using @alray

Useful links for the HTC One:
nkk71's SuperGUIDE to returning 100% back to stock
Flashing requirements chart by nkk71
HTC1Guru.com by crushalot

The Following User Says Thank You to alray For This Useful Post: [ Click to Expand ]
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes