Default Disable google crap, now I get 3 days of battery but how to turn off error messages?

Lately, Google updated all their system apps like Google Play, Google "Services" and all that stuff. The problem I had been having was that it was eating away about 60% battery every 4 hours on standby. My phone was really hot all the time. At my job, I'm on my feet and walking around for about 12 hours a day and need to always have my phone on me and be able to receive phone calls. So this was getting really annoying.

I tried numerous methods all over the internet to get it fixed but non of that stuff really did anything. I tried using LBE to deny GPS permissions and that didn't fix it. LBE doesn't have the ability to deny the wakelock or run-during-standby permissions so it wasn't able to help me much more.

I even tried buying the full version of Greenify to hibernate Google Play, Google Services, as well as all the individual apps that spam-sync everything. It worked for like a week but then Google must of updated everything and now it seems to bee immune to Greenify.

Since Google Play services is the one doing most of the battery spamming, I tried to disable it in settings>applications>all but it's blocked from being disabled.
So I have to disable Google Framework. This makes my battery last forever on standby now but it causes problems. First, it makes the gps not seem to work, The gps icons will show, but no apps can get my location. I have checked LBE and it's not blocking anything anymore so that's no what's making gps not work. The other problem is that I get an annoying message telling me that google play services has stopped working. It's only a problem because it's annoying. The third problem is that Google play doesn't work but I don't care about that.
Does anybody know how to make Google Play services disable-able from the applications menu? If not, perhaps there's a way to make those error messages go away and re-enable gps?