ToqAN Fixes Android 5.0 Notification Bug on Qualcomm Toq

The Qualcomm Toq is probably one of the lesser known smartwatches on the market … more

How to Root and Unlock the Google Nexus 6 on a Mac – XDA TV

In the past, XDA Developer TV Producer droidmodd3rx has shown you how to … more

Set Up Your MediaTek Device with Comprehensive Beginner’s Guide

As can be seen with the use of MediaTek chips in Android One devices … more

Sony Updates AOSP Sources to Android 5.0.1

Just a few days ago, Sony did an utterly fantastic job by pushing out numerous device trees for … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Fastboot and adb won't recognize HTC one

OP playboypaul

22nd July 2014, 04:17 AM   |  #1  
OP Senior Member
Flag Vancouver
Thanks Meter: 2
 
111 posts
Join Date:Joined: Feb 2012
Donate to Me
More
I've installed all the correct drivers and my computer can recognize my phone, once in boot loader mode I can find the model of my phone with terminal but anything else I try like adb or fastboot with HTC one toolkit says no device is found?? I'm just trying to root and even go s-off again but nothing is working l. Only command that works is , adb devices after that its no device found. I cannot root with toolkit or terminal I get same message.

Is there anyone that can help me with this?

Please and thank you

Sent from my HTC One using XDA Free mobile app
22nd July 2014, 05:23 AM   |  #2  
alray's Avatar
Senior Member
Flag Montreal, Quebec
Thanks Meter: 1,386
 
3,589 posts
Join Date:Joined: May 2012
Donate to Me
More
Quote:
Originally Posted by playboypaul

I've installed all the correct drivers and my computer can recognize my phone, once in boot loader mode I can find the model of my phone with terminal but anything else I try like adb or fastboot with HTC one toolkit says no device is found?? I'm just trying to root and even go s-off again but nothing is working l. Only command that works is , adb devices after that its no device found. I cannot root with toolkit or terminal I get same message.

Is there anyone that can help me with this?

Please and thank you

Sent from my HTC One using XDA Free mobile app

  1. adb commands only works from custom recovery or from a booted rom with usb debugging enabled
  2. fastboot commands only works from bootloader
  3. don't use toolkits, use fastboot and adb directly from a command window.
apart from the toolkit, if the drivers are correctly installed and your device is detected with "adb devices"/"fastboot devices" there is no reason other commands won't works.

you can also check nkk71's guide, there is guide in the FAQ to install drivers correctly.

You could also try to use adb and fastboot from a linux live cd/usb (ubuntu for example)
Last edited by alray; 22nd July 2014 at 05:25 AM.
22nd July 2014, 07:59 AM   |  #3  
whpsnp's Avatar
Senior Member
Thanks Meter: 33
 
255 posts
Join Date:Joined: Dec 2010
More
Most likely you just need to enable usb debugging in settings.

Sent from my HTC One using Tapatalk
22nd July 2014, 05:44 PM   |  #4  
OP Senior Member
Flag Vancouver
Thanks Meter: 2
 
111 posts
Join Date:Joined: Feb 2012
Donate to Me
More
USB debugging is enabled when I try this, all the tutorials ive read pretty much start with telling u that.

I've also used the command window to try troubleshoot why toolkit didn't work and same result.

When I try push a file like twrp I get no device attached.

Sent from my HTC One using XDA Free mobile app
22nd July 2014, 05:44 PM   |  #5  
OP Senior Member
Flag Vancouver
Thanks Meter: 2
 
111 posts
Join Date:Joined: Feb 2012
Donate to Me
More
I'll try again and post a screenshot of command window

Sent from my HTC One using XDA Free mobile app
23rd July 2014, 02:39 AM   |  #6  
OP Senior Member
Flag Vancouver
Thanks Meter: 2
 
111 posts
Join Date:Joined: Feb 2012
Donate to Me
More
Figured it out thanks for the help

Sent from my HTC One using XDA Free mobile app
23rd July 2014, 06:39 PM   |  #7  
OP Senior Member
Flag Vancouver
Thanks Meter: 2
 
111 posts
Join Date:Joined: Feb 2012
Donate to Me
More
Had root for the day then woke today to error saying this device does not have proper root access?

I have twrp installed and working tried to reflash SuperSU and all my system apps are closing .

Sent from my HTC One using XDA Free mobile app

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes