Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Flashing fw 5/6.xx.xxx.x over 3.xx.xxx.x

OP _saiko

11th August 2014, 08:41 AM   |  #1  
OP Member
Flag Zagreb
Thanks Meter: 5
 
46 posts
Join Date:Joined: Jan 2012
More
Am I safe to flash 4.19.401.11 over 3.62.401.1 and then go to 6.06.401.1 ?

Im currently on 3.62.401.1 custom firmware by sneakyghost and want to upgrade to 6.06.401.1.
From what I read flashing 5.xx.xxx.x over gpe 3.xx.xxx.x results in a bricked One.
There's no real explanation or clarification what's a safe procedure, hence my question.

Logic tells me to gradually flash between "major" versions of fw but don't wan't to risk it..
The x.xx.401.x firmwares are WWE, not GPE right?)
11th August 2014, 09:40 AM   |  #2  
donkeykong1's Avatar
Senior Member
Flag Sesvete, Zagreb
Thanks Meter: 768
 
1,935 posts
Join Date:Joined: Aug 2012
More
Quote:
Originally Posted by _saiko

Am I safe to flash 4.19.401.11 over 3.62.401.1 and then go to 6.06.401.1 ?

Im currently on 3.62.401.1 custom firmware by sneakyghost and want to upgrade to 6.06.401.1.
From what I read flashing 5.xx.xxx.x over gpe 3.xx.xxx.x results in a bricked One.
There's no real explanation or clarification what's a safe procedure, hence my question.

Logic tells me to gradually flash between "major" versions of fw but don't wan't to risk it..
The x.xx.401.x firmwares are WWE, not GPE right?)

There were some bricks due to skipping major versions, so I would recomend to flash one at a time. .401 is WWE version
12th August 2014, 03:31 PM   |  #3  
alray's Avatar
Senior Member
Flag Montreal, Quebec
Thanks Meter: 1,385
 
3,589 posts
Join Date:Joined: May 2012
Donate to Me
More
Quote:
Originally Posted by _saiko

Am I safe to flash 4.19.401.11 over 3.62.401.1 and then go to 6.06.401.1 ?

Im currently on 3.62.401.1 custom firmware by sneakyghost and want to upgrade to 6.06.401.1.
From what I read flashing 5.xx.xxx.x over gpe 3.xx.xxx.x results in a bricked One.
There's no real explanation or clarification what's a safe procedure, hence my question.

Logic tells me to gradually flash between "major" versions of fw but don't wan't to risk it..
The x.xx.401.x firmwares are WWE, not GPE right?)

if you are updating your firmware by flashing firmware.zip from OTA files, you MUST do it incrementally or you WILL brick your phone. Why?
---> firmware.zip packages from OTA are not containing all the firmware files (recovery, sbl, radio, boot, hboot, drivers and much more) but only some of them. if you flash, i.e, a 5.xx.xxx.x over a 3.xx.xxx.x you will brick because the 5.x firmware was designed to work with some existing files of the 4.x firmware that are not included in the 5.x firmware.

---> the only safe way to flash a higher firmware, without doing it incrementally is by using a frimware.zip from a RUU. Fimware.zip from RUU are complete packages containing all firmware files.

see image below, you'll understand what I mean

12th August 2014, 04:09 PM   |  #4  
OP Member
Flag Zagreb
Thanks Meter: 5
 
46 posts
Join Date:Joined: Jan 2012
More
http://forum.xda-developers.com/show....php?t=2316726
Quote:
Originally Posted by alray

if you are updating your firmware by flashing firmware.zip from OTA files, you MUST do it incrementally or you WILL brick your phone. Why?
---> firmware.zip packages from OTA are not containing all the firmware files (recovery, sbl, radio, boot, hboot, drivers and much more) but only some of them. if you flash, i.e, a 5.xx.xxx.x over a 3.xx.xxx.x you will brick because the 5.x firmware was designed to work with some existing files of the 4.x firmware that are not included in the 5.x firmware.

---> the only safe way to flash a higher firmware, without doing it incrementally is by using a frimware.zip from a RUU. Fimware.zip from RUU are complete packages containing all firmware files.

see image below, you'll understand what I mean

Thanks for the clarification!
Im not planning to using OTA partial firmwares but combined firmware zip files from users like Sneakyghost or Vomer which should have all components.
http://forum.xda-developers.com/show....php?t=2365506
http://forum.xda-developers.com/show....php?t=2316726

In any case ill go 3.xx.xxx.x -> 4.xx.xxx.x -> 5.xx.xxx.x -> 6.xx.xxx.x just to be safe!
Last edited by _saiko; 12th August 2014 at 04:17 PM.
Post Reply Subscribe to Thread

Tags
brick, firmware, gpe, safe flashing
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes