Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Help about camera can not be used in 4.4.4

OP ericbaggio

31st July 2014, 04:40 AM   |  #1  
OP Junior Member
Thanks Meter: 1
 
17 posts
Join Date:Joined: Jul 2011
Hi all, I meet one issue that the camera can not be used after installed any 4.4.4 ROM such as Sultan's and Shantur's UnO ROMs.

sometimes, I can see the icon of camera, but once I press it, it will say 'can not connect to camera' or 'the app is not installed' and then the icon of camera will disappear, while sometimes, I just can not see the icon of camera.

I tried to reboot, no luck, tried to install other camera, such as Google camera, still no luck.

But I install back to Sultan's 4.4.2 ROM, the camera works well.

Does anybody meet such issue before? How to fix it? Thanks in advance.
1st August 2014, 08:42 AM   |  #2  
OP Junior Member
Thanks Meter: 1
 
17 posts
Join Date:Joined: Jul 2011
I tried more times on different version Sultan's ROM, I found that last camera working ROM is the version Mar25, and the later updated version ROM from Apr13 was installed, the camera will not work, so it is not related to 4.4.4 or 4.4.3, it is a little strange and bother me a lot, I am so like the latest 4.4.4 ROM. below are the change log from Sultan's ROM, does anybody have any idea about it? thanks.

Apr 13, 2014:
ROM:
*Latest upstream CyanogenMod changes
*Switched to upstream CM camera app (thanks to AceEnablementProject for their camerawrapper)
*Fixed encryption failing on /data unmount

Kernel:
Sultan kernel Pure v1.4.0:
*Backported GPU driver from CAF kk_2.7_rb1.33 (thanks to Flemmard)
*Backported WiFi driver from Google Nexus 5 kernel (thanks to Flemmard)
*Backported wireless stack from Google Nexus 5 kernel
*Added a few minor updates to ION drivers from CAF
*Fixed touchscreen not responding when waking the device from sleep
*Added some CAF patches to camera drivers
*Removed Interactive and Lagfree governors

Mar 25, 2014:
ROM:
*Latest upstream CyanogenMod changes
*Fixed in-call audio
*Increased speaker volume

Kernel:
Sultan kernel Pure v1.3.1:
*Fixed long delay in camcorder (big thanks to paulb-nl and CAF)
*Added missing PMEM_CACHE_FLUSH function (thanks to Johnnyslt)
11th August 2014, 09:24 AM   |  #3  
OP Junior Member
Thanks Meter: 1
 
17 posts
Join Date:Joined: Jul 2011
Anybody can help me out?

Really like my sensation, want to use 4.4.4 ROM...
21st August 2014, 08:25 AM   |  #4  
OP Junior Member
Thanks Meter: 1
 
17 posts
Join Date:Joined: Jul 2011
finally give up, have tried all I can do, re-install the firmware, format the SD card, etc, still no luck,
22nd August 2014, 11:19 PM   |  #5  
Senior Member
Thanks Meter: 3
 
136 posts
Join Date:Joined: May 2009
Quote:
Originally Posted by ericbaggio

finally give up, have tried all I can do, re-install the firmware, format the SD card, etc, still no luck,


What launcher are you using? You may want be sure to do a clean install.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes