TWRP for Nexus 6 and 9 Available, Unofficial CM12 Alpha for HTC Explorer! – XDA TV

Team Win Recovery Project for the Nexus 6 and Nexus … more

Jolla Tablet Announced: The Second Sailfish OS Device

A little over a year ago, Jolla released its first smartphone with the brand new Jolla … more

Android One Devices Get Unofficial CM12 Port

Android One was initially announced right before Android Lollipop. By releasing these cheap, yet … more

WhatsApp Decides to Protect Your Data

When Facebook bought WhatsApp for the absurdly large sum of $19bn back in February, they took the tech … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[DRIVER] [GUIDE] Finally, how to get fastboot to work on Windows 8.1

OP izi501

25th August 2014, 01:19 AM   |  #1  
izi501's Avatar
OP Recognized Contributor
Flag Nantes
Thanks Meter: 465
 
892 posts
Join Date:Joined: Jul 2012
More
Hi guys,

One issue appeared with Windows 8.1 which I found very annoying : the Wildfire S wasn't recognized anymore in fastboot mode. Not very useful to flash system or recovery images... Usually, the solution was to use Linux, but one cannot (or doesn't want to) install Linux on one's PC :P
So thanks to Auth from 4pda and @niks255 (I'm actually only reposting it here), we now have a way to make these drivers work on Windows. Here's what you need to know :

The actual issue is caused by a lack of BOS descriptor : the Wildfire S doesn't provide any although it has USB > 2.00. Windows 8 accepted it, but not 8.1.
To use this patch, you must have KB296791 (http://support.microsoft.com/kb/2967917/en-us) installed. To check this just go to Control Panel - Programs and features - View installed updates and type KB296791 in the searchbox on the right top corner. If you don't have this update installed, just update your Windows using Windows Update.
Then, download the attached registry key file, Fastboot.reg.txt and rename it to Fastboot.reg.
Open an admin console by right-clicking on the Start button and choosing Console (admin). Then type the regedit command. The registry manager should now open.
Choose File/Import key and import Fastboot.reg.

Done ! It was that simple. Now you can use fastboot whenever you wish
Attached Files
File Type: txt Fastboot.reg.txt - [Click for QR Code] (324 Bytes, 353 views)
Last edited by izi501; 25th August 2014 at 01:44 AM.
The Following 9 Users Say Thank You to izi501 For This Useful Post: [ View ]
25th August 2014, 04:03 AM   |  #2  
dr3amsINdigital's Avatar
Senior Member
Thanks Meter: 52
 
179 posts
Join Date:Joined: Jul 2012
More
This isn't limited to just the Wildfire S, right? I have an HTC One S that I'd like to get this working with.

EDIT: Just tried it and it worked! Thank you so much for posting this!!!
Last edited by dr3amsINdigital; 25th August 2014 at 05:06 AM.
25th August 2014, 08:41 AM   |  #3  
izi501's Avatar
OP Recognized Contributor
Flag Nantes
Thanks Meter: 465
 
892 posts
Join Date:Joined: Jul 2012
More
Quote:
Originally Posted by dr3amsINdigital

This isn't limited to just the Wildfire S, right? I have an HTC One S that I'd like to get this working with.

EDIT: Just tried it and it worked! Thank you so much for posting this!!!

Yeah sure you can use this with every phone Glad it helped you !
The Following 2 Users Say Thank You to izi501 For This Useful Post: [ View ]
25th August 2014, 01:11 PM   |  #4  
csoulr666's Avatar
Senior Member
Flag Aligarh
Thanks Meter: 407
 
1,436 posts
Join Date:Joined: Jun 2011
More
Quote:
Originally Posted by izi501

Hi guys,

One issue appeared with Windows 8.1 which I found very annoying : the Wildfire S wasn't recognized anymore in fastboot mode. Not very useful to flash system or recovery images... Usually, the solution was to use Linux, but one cannot (or doesn't want to) install Linux on one's PC :P
So thanks to Auth from 4pda and @niks255 (I'm actually only reposting it here), we now have a way to make these drivers work on Windows. Here's what you need to know :

The actual issue is caused by a lack of BOS descriptor : the Wildfire S doesn't provide any although it has USB > 2.00. Windows 8 accepted it, but not 8.1.
To use this patch, you must have KB296791 (http://support.microsoft.com/kb/2967917/en-us) installed. To check this just go to Control Panel - Programs and features - View installed updates and type KB296791 in the searchbox on the right top corner. If you don't have this update installed, just update your Windows using Windows Update.
Then, download the attached registry key file, Fastboot.reg.txt and rename it to Fastboot.reg.
Open an admin console by right-clicking on the Start button and choosing Console (admin). Then type the regedit command. The registry manager should now open.
Choose File/Import key and import Fastboot.reg.

Done ! It was that simple. Now you can use fastboot whenever you wish

I believe a really big thank you is required............ FINALLY I can flash stuff via my PC. Thanks a ton for reposting this here!
8th October 2014, 11:23 PM   |  #5  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Oct 2014
Thumbs up
Thank you!! I've found so many forums around the internet where people have the same problem with no fix; this is great! This worked to make fastboot recognize my HTC Incredible 4g LTE (fireball) in the command prompt! Hallelujah!
7th November 2014, 09:36 PM   |  #6  
Senior Member
Thanks Meter: 89
 
450 posts
Join Date:Joined: May 2012
More
i have this patch installed and applied reg file but it still not work.

8th November 2014, 08:32 AM   |  #7  
izi501's Avatar
OP Recognized Contributor
Flag Nantes
Thanks Meter: 465
 
892 posts
Join Date:Joined: Jul 2012
More
Quote:
Originally Posted by evildog1

i have this patch installed and applied reg file but it still not work.

Did you install Wildfire S drivers ?
8th November 2014, 11:47 AM   |  #8  
Senior Member
Thanks Meter: 89
 
450 posts
Join Date:Joined: May 2012
More
Quote:
Originally Posted by izi501

Did you install Wildfire S drivers ?

No, i don't have it installed.
8th November 2014, 02:19 PM   |  #9  
izi501's Avatar
OP Recognized Contributor
Flag Nantes
Thanks Meter: 465
 
892 posts
Join Date:Joined: Jul 2012
More
Quote:
Originally Posted by evildog1

No, i don't have it installed.

Then it's logical your device won't ever get detected :P

Post Reply Subscribe to Thread

Tags
drivers, fastboot, windows 8.1
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes