FORUMS

[Q] Cannot Root A510

13 posts
Thanks Meter: 0
 
By oldguardmd, Junior Member on 4th September 2014, 02:01 AM
Post Reply Subscribe to Thread Email Thread
I have been looking to Root my A510 and drop KitKat on it, but I am stuck trying to install the recovey,img

Steps completed so far:

Bootloader unlocked
adb reboot-bootloader
fastboot oem unlock
fastboot reboot
Obtained the recovery image 6.0.4.5
Loaded recovery image
adb reboot bootloader
fastboot flash recovery c:\AndroidRootTablet\recovery.img
fastboot reboot (holding volume down)
Just boots up normally... I can get into the stock recovery using adb reboot recovery, but I see no way to add the recovery image...

A510 version is 4.1.2

I probably have this out of order, but I tried to root the tablet first, but that didn't work either. A few questions:

-- Do I need root before installing the recovery.img?
-- What is the current recommendation for rooting the A510?

This is what I tried to use for rooting:

http://theunlockr.com/2013/06/15/how...onia-tab-a510/
Last edited by oldguardmd; 4th September 2014 at 03:19 AM. Reason: More detail...
 
 
4th September 2014, 09:35 AM |#2  
Shreps's Avatar
Recognized Developer
Flag Paris
Thanks Meter: 1,207
 
Donate to Me
More
No need to root before flashing a recovery

You have to reboot in recovery directly after flashing it via fastboot and flash the zip "disable stock recovery"
With a JB bootloader you have to : Hold Volume- (**), and when vibrate, release it and hold Volume+(*) until the recovery load

If you reboot in Normal mode, the Acer ROM will erase the recovery.

Check the initial CWM thread with it's installation guide: http://forum.xda-developers.com/show....php?t=1866378
Could be applied with any version of custom recovery
The Following User Says Thank You to Shreps For This Useful Post: [ View ]
6th September 2014, 01:37 AM |#3  
OP Junior Member
Thanks Meter: 0
 
More
A510 Updated to KitKat
Thank you sir for you help. That hit the spot. I greatly appreciate the work you are doing with the A510.
Post Reply Subscribe to Thread

Tags
a510, image, recovery
Previous Thread Next Thread
Thread Tools
Display Modes