FORUMS

Sunday Debate: Which Factors Caused HTC’s Woes?

Join us in a fun Sunday Debate on HTC’s situation. Come with your … more

HTC’s New Ad Campaign And What It Really Means

HTC has just released three new blind test adverts comparing app loading … more

XDA Picks: Best Apps of the Week (June 27 – July 4)

Apps are at the front and center of any smartphone experience, and with over a … more

HTC One M9 Developer Edition Android 5.1 OTA

The Developer Edition of the HTC One M9 is receiving an over-the-air update to Android 5.1. … more

[ROM] HDX Nexus [Safestrap Version] v1.0.1

902 posts
Thanks Meter: 1,268
 
Post Reply Subscribe to Thread Email Thread
*** USE AT YOUR OWN RISK! I AM NOT RESPONSIBLE IF THINGS GO WRONG. ***



Introduction
Quote:

I am very proud to bring you HDX Nexus Safestrap ROM. This is for both the Kindle Fire HDX 7" and 8.9" WIFI only variants and brings full AOSP functionality which are using Safestrap. You must be running stock firmware .3.2.4 - 3.2.8


Features
Quote:

- Full Jelly Bean 4.2.2 AOSP functionality


Bug Reports
Quote:

- Please use the Bugs section on this thread, it will make it a lot easier to to keep track.


Fresh Installation
Quote:

- Flash safestrap-thor-nexus-rom.zip or safestrap-apollo-nexus-rom.zip
- Flash hdx-nexus-gapps-v1.2.zip
- Then flash any addons
- If coming from any other ROM then do a factory reset.
- Reboot and enjoy.


Upgrading From Previous Version
Quote:

- Flash safestrap-thor-nexus-rom.zip or safestrap-apollo-nexus-rom.zip
- Flash hdx-nexus-gapps-v1.2.zip
- Wipe Dalvik Cache and Cache
- Then flash any addons
- Reboot and enjoy.


Changelog
Quote:

- x -> v1.0.1

Code:
- Initial Release.
- Branched from mainline HDX Nexus ROM v2.0.5



Downloads


Add-Ons

FAQ
TBD

Finally
Quote:

- Thank you to everyone for your ongoing support and to everyone that made a Donation.

XDA:DevDB Information
HDX Nexus Safestrap, ROM for the Amazon Kindle Fire HDX 7" & 8.9"

Contributors
ggow
ROM OS Version: 4.2.x Jelly Bean
ROM Kernel: Linux 3.4.x
ROM Firmware Required: .3.2.4 - 3.2.8
Based On: AOSP JDQ39

Version Information
Status: Stable
Current Stable Version: 1.0.1
Stable Release Date: 2015-02-07

Created 2015-02-07
Last Updated 2015-02-07
The Following 14 Users Say Thank You to ggow For This Useful Post: [ View ]
 
 
7th February 2015, 07:17 PM |#4  
ggow's Avatar
OP Senior Member
Thanks Meter: 1,268
 
Donate to Me
More
Info 2 Update
Hello All,
Files are now up
The Following 5 Users Say Thank You to ggow For This Useful Post: [ View ]
8th February 2015, 01:17 AM |#5  
Member
Thanks Meter: 1
 
More
Thumbs up
Ggow much appreciated that safetrap version is coming back!

Just to clarify that this rom will work with devices that got upgraded to 4.5.2 and then downgraded by ACS to 3.2.7/8 and rooted with safetrap working.

Here are some questions that I'm sure people will be curious about:
- I'm currently on 2.0.2 and root checker says root is enabled, but couldn't find the supersu app. How does it work? Do i need to flash supersu?
- Can you install xposed with modules on this version? For example to mod notifications bar, status bar, power menu, etc.
- can I safely upgrade from the older 2.0.2 to this version?
- what about addons like the dolby digital? I assume its safe to flash too?
- current build.prop ids the device as Nexus HDX and tgere are a lot of apps on play store that are not compatible with the device, but they work just fine installed from another market (say 1mobile). Can we do something about it?

Sorry for so many questions, but i tried reading most stuff from the other thread but for some reason search in thread is disabled (no idea why).

Cheerz!
8th February 2015, 03:50 AM |#6  
Member
Thanks Meter: 11
 
More
Awesome, thanks!!!
8th February 2015, 09:47 AM |#7  
ggow's Avatar
OP Senior Member
Thanks Meter: 1,268
 
Donate to Me
More
Quote:
Originally Posted by johim

Ggow much appreciated that safetrap version is coming back!

Just to clarify that this rom will work with devices that got upgraded to 4.5.2 and then downgraded by ACS to 3.2.7/8 and rooted with safetrap working.

Correct, yes.


Here are some questions that I'm sure people will be curious about:
- I'm currently on 2.0.2 and root checker says root is enabled, but couldn't find the supersu app. How does it work? Do i need to flash supersu?

The ROM is pre-rooted with the su binary and a daemon. SuperSU is a root manager so its up to you if want that functionality.


- Can you install xposed with modules on this version? For example to mod notifications bar, status bar, power menu, etc.

Yes you can.


- can I safely upgrade from the older 2.0.2 to this version?

Yes


- what about addons like the dolby digital? I assume its safe to flash too?

Yes


- current build.prop ids the device as Nexus HDX and tgere are a lot of apps on play store that are not compatible with the device, but they work just fine installed from another market (say 1mobile). Can we do something about it?

No matter how I modify the build.prop, google play store ends up not playing nice. So no not at the moment. Market helper used to work for this problem but seems to but patched now on googles servers.


Sorry for so many questions, but i tried reading most stuff from the other thread but for some reason search in thread is disabled (no idea why).

Cheerz!

See my responses above. I'll add some information to the FAQ when possible.

Sent from my Nexus 6 using Tapatalk
9th February 2015, 08:57 PM |#8  
Member
Thanks Meter: 1
 
More
OK, I updated and flashed all gapps and addons. Everything works!

Then I tried installing Xposed Framework, and on reboot the result was black screen after rom bootup (right after android animation). Waited like 2-3 minutes, but nothing. Then had to force reboot it via power button. After reboot everything works again with Xposed installed. No idea what happened. Any guidelines on where I can check logs probably.

havent tried any module yet, but it would be nice if we keep a list of compatible and safe modules.

Question: can any of the xposed modules trip eFuse or break stock kernel (as rom is running on top of it) or safetrap makes it safe so any changes to system would be just to the slot rom?
9th February 2015, 09:52 PM |#9  
ggow's Avatar
OP Senior Member
Thanks Meter: 1,268
 
Donate to Me
More
Quote:
Originally Posted by johim

OK, I updated and flashed all gapps and addons. Everything works!

Then I tried installing Xposed Framework, and on reboot the result was black screen after rom bootup (right after android animation). Waited like 2-3 minutes, but nothing. Then had to force reboot it via power button. After reboot everything works again with Xposed installed. No idea what happened. Any guidelines on where I can check logs probably.

havent tried any module yet, but it would be nice if we keep a list of compatible and safe modules.

Question: can any of the xposed modules trip eFuse or break stock kernel (as rom is running on top of it) or safetrap makes it safe so any changes to system would be just to the slot rom?

Use this verison of Xposed found here.

Try Gravitybox (JB).

I don't know if any of the modules can trigger the efuse. You are correct, in theory Safestrap makes it so that any changes should only occur in that slot.
11th February 2015, 09:54 AM |#10  
Member
Flag Glenn heights
Thanks Meter: 13
 
More
So far this ROM has been excellent. Great job and thanks a lot!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes