Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

External SD card and G PAD... try to clarify

OP parsifal968

25th November 2014, 09:25 PM   |  #131  
Senior Member
Flag Cambridge
Thanks Meter: 242
 
926 posts
Join Date:Joined: Sep 2011
More
Quote:
Originally Posted by tskisiu

I have not had a single "bad removal" when running on a RedKernel and CM11 for 2 months (as tested with SD Card Monitor). RedKernel: http://forum.xda-developers.com/lg-g...ernel-t2856297
When I flash a "vanilla" kernel from any recent CM11 the errors are immediately back, usually when the tablet stays in deep sleep. Unfortunately, I have had also this issue with the new Lollipop from this thread: http://forum.xda-developers.com/lg-g...rx21m-t2941207

Actually the RedKernel is very good. I use v9 because on v10 I had strange battery drain during sleep. The only problem I have encountered is related to WiFi switching: when I move to a different network it does not re-connect automatically and the WiFi is unresponsive. The only way to fix it is to switch to the Airplane Mode and back., but while it works fine with the known networks it has some problems scanning for the new ones. It can be quite irritating while travelling for instance.

p.s. my sd card is exFAT formatted

Are you using 4.2.2 base or 4.4.2? I have noticed that if I am on 4.2.2 base then no matter what ROM/kernel I am on I don't get any bad unmounts of the SDcard. As soon as I switch to 4.4.2 base files then the unmounts start happening. This is annoying because I want to use redkernel with 4.4.2 base so I don't have the brightness issues. Any suggestions welcome!
25th November 2014, 09:33 PM   |  #132  
Junior Member
Thanks Meter: 3
 
17 posts
Join Date:Joined: Nov 2010
I am on 4.4.2 base CM11 M12 snapshot + redkernel r09 + exfat sd card
15th December 2014, 03:46 AM   |  #133  
muiriddin's Avatar
Senior Member
Flag Mid-Atlantic
Thanks Meter: 104
 
333 posts
Join Date:Joined: Feb 2013
More
Okay, my ext4 approach just crapped out for me on stock. I did run for a long time without having the bad removal storm, but I have now had one. My best approach at this time is to flash a rom and run either redkernel (in 4.4 based roms) or redkernel/manikernel (in lollipop roms). I have lots of testing without a problem with 4.4 and redkernel. So far with Lollipop I have tried both redkernel and manikernel but I obviously do not have as much time as redkernel on 4.4 (it hasn't been out as long).



I still hope that LG will release a new lollipop build which solves this issue, but the roms I'm running with the kernels I use seem to make the problem go away, stock just doesn't work well with sdcards from what I can tell. Yet I know it isn't a hardware problem since the problem did not occur on 4.2 and does not occur for me on slimkat with the redkernel...



If anyone has bad removal problems on lollipop with either one of these kernels please post here...
15th December 2014, 09:55 PM   |  #134  
Senior Member
Thanks Meter: 63
 
246 posts
Join Date:Joined: Apr 2013
Just to bring the conversation over to this thread..

When I select a few gigs of video, it usually takes about 30 minutes or so to copy. While it's copying, the tablet goes to sleep after a few minutes and that is when the copy fails due to disk unmount.
The Following User Says Thank You to Deltadroid For This Useful Post: [ View ]
16th December 2014, 05:59 PM   |  #135  
muiriddin's Avatar
Senior Member
Flag Mid-Atlantic
Thanks Meter: 104
 
333 posts
Join Date:Joined: Feb 2013
More
Quote:
Originally Posted by Deltadroid

Just to bring the conversation over to this thread..

When I select a few gigs of video, it usually takes about 30 minutes or so to copy. While it's copying, the tablet goes to sleep after a few minutes and that is when the copy fails due to disk unmount.

Okay, I can try something like that. I have been moving data around lately and the screen has been going off, however I typically am moving a bunch of small files that collectively add up to a large amount of data...

Additional Note:

The key thing I have been trying to reproduce is a scenario which results in a "bad removal" from the sdcard monitoring tool. From my own personal observations a bad removal will often result in a mount unmount storm occurring which then can put the tablet in a "bad state" as to sdcard usage. This "bad state" is typically a situation in which the card shows as mounted, but no files are visible and its capacity is listed as 0 in size. In addition I have also observed a situation in which the card could no longer be unmounted without rebooting the tablet itself.
Last edited by muiriddin; 17th December 2014 at 03:54 PM. Reason: added additional note
20th December 2014, 03:10 PM   |  #136  
Senior Member
Thanks Meter: 67
 
143 posts
Join Date:Joined: Jul 2011
More
I was investigating the problem and I think I found the cause and the solution.

The cause:
According to my findings the bad dismount while deep sleeping is caused by the C3* state (Power Collapse) which is the deepest sleep state.
While in this state the sdcard check routine timeouts and a bad dismount occurs.

The solution (root required):
When I had the Nexus4 I remember the C3 state was off by default and enabling it caused issues in some cases...
So I tried to disable it on the GPad and this cured the bad dismount.

This may lead to a little higher battery drain while in standby.... the device deep sleeps just fine anyway.

Attached to this post you'll find the script (remove the .zip extension after the download) you need to place in system/etc/init.d (if your kernel supports init.d... stock one doesn't)... alternatively you may use Script Manager and execute the script with ROOT privileges.

I tested this on my GPad running Mahdi 2.9 ROM (KK) and mani.Kernel... It SHOULD work on any ROM/KERNEL combinations....

* Infos about C-States may be found here.

Merry Xmas!
Attached Files
File Type: zip 01externalsdfix.zip - [Click for QR Code] (676 Bytes, 18 views)
20th December 2014, 04:59 PM   |  #137  
Senior Member
Thanks Meter: 63
 
246 posts
Join Date:Joined: Apr 2013
I fixed my unmount problem by formatting my sdcard with cwm recovery. I had no idea my card was exfat, because it was mounting ok and it seemed to work ok most of the time.. But, it caused major instabilities in the system overall.

It seems to make a big difference which program you use to format the card with.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes