Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,579 Members 43,845 Now Online
XDA Developers Android and Mobile Development Forum

microSD showing 0 capacity requires unmount/remount to fix

Tip us?
 
jarod004
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 25
Join Date: Jun 2014
Question microSD showing 0 capacity requires unmount/remount to fix

Hello everyone,

I am experiencing an odd issue with my G PAD 8.3. It seems to randomly "appear" that the microSD is unmounted (when i check my filemanager, i am unable to enter /storage/external_SD... However, when I go to settings -> storage, the SD card is not exactly unmounted as I still have the Unmount SD card option still available. When I check the usage though its showing as 0GB. So what I do is, I unmount the SD from the settings menu, then remount it from the same menu thereafter. It will fix the issue, but after some time, it will again show as mounted but 0GB used.

My current setup is:
ROM: Slimkat 4.4.4 latest weekly build
Sdcard: 32 GB Sandisk

What I suspect is either of the following:
1. A bug with the ROM (since there isnt a stable release of Slimkat on the g pad)
2. An issue with the microSD. It might fail soon
3. An issue with one of the apps. Might be worth noting that I have foldermount installed on my tablet. since it is an application that mounts and unmounts directories from the microSD, perhaps this may cause the problem, though i havent seen anyone who have experienced a similar issue.

Any ideas what could cause this?
 
sleekmason
Old
#2  
sleekmason's Avatar
Senior Member
Thanks Meter 214
Posts: 439
Join Date: Dec 2013
Location: Fayetteville
Quote:
Originally Posted by jarod004 View Post
Hello everyone,

I am experiencing an odd issue with my G PAD 8.3. It seems to randomly "appear" that the microSD is unmounted (when i check my filemanager, i am unable to enter /storage/external_SD... However, when I go to settings -> storage, the SD card is not exactly unmounted as I still have the Unmount SD card option still available. When I check the usage though its showing as 0GB. So what I do is, I unmount the SD from the settings menu, then remount it from the same menu thereafter. It will fix the issue, but after some time, it will again show as mounted but 0GB used.

My current setup is:
ROM: Slimkat 4.4.4 latest weekly build
Sdcard: 32 GB Sandisk

What I suspect is either of the following:
1. A bug with the ROM (since there isnt a stable release of Slimkat on the g pad)
2. An issue with the microSD. It might fail soon
3. An issue with one of the apps. Might be worth noting that I have foldermount installed on my tablet. since it is an application that mounts and unmounts directories from the microSD, perhaps this may cause the problem, though i havent seen anyone who have experienced a similar issue.

Any ideas what could cause this?
Lookup sandisk sdcard problems on google.
Sandisk was having issues with some of their cards. Pop in a different one to make sure its not the tablet.
 
jarod004
Old
#3  
Junior Member - OP
Thanks Meter 1
Posts: 25
Join Date: Jun 2014
Quote:
Originally Posted by sleekmason View Post
Lookup sandisk sdcard problems on google.
Sandisk was having issues with some of their cards. Pop in a different one to make sure its not the tablet.
Thanks mate, ill pop one right in when I find one lying around. I might also try to slow format to FAT32 and then format the card using the tablet and see if it helps.... Just wondering if anyone else is having a similar issue. Been googling around, and the closest things I can see are people that are having issues when their microSD randomly gets unmounted... in my case its not really unmounted, just showing capacity is 0 and after a umount/remount cycle, it works again then shows 0gb again after some time...

Thanks for your response.
 
MattNoir
Old
#4  
Junior Member
Thanks Meter 2
Posts: 16
Join Date: Jun 2011
Location: Košice
Quote:
Originally Posted by jarod004 View Post
Thanks mate, ill pop one right in when I find one lying around. I might also try to slow format to FAT32 and then format the card using the tablet and see if it helps.... Just wondering if anyone else is having a similar issue. Been googling around, and the closest things I can see are people that are having issues when their microSD randomly gets unmounted... in my case its not really unmounted, just showing capacity is 0 and after a umount/remount cycle, it works again then shows 0gb again after some time...

Thanks for your response.
Same issue here.
Slimkat v4.4.4 latest weekly build
SanDisk 32GB ultra class10

Not using that folder app and SD worked normally before slimkat so I assume it's rom bug, and it's sad and I'm thinking about going back to stock. And one more thing - installed SD monitor and SD unmounts on screen off and then remounts when you turn screen back on. As no problems were detected on stock kitkat I think it's another bug of slimkat. Where can I report it?
 
muiriddin
Old
#5  
muiriddin's Avatar
Senior Member
Thanks Meter 84
Posts: 243
Join Date: Feb 2013
Location: Mid-Atlantic
I do not trust SanDisk anymore. Most of my earlier trouble was caused by a bad card that failed way to early from them.
 
MattNoir
Old
#6  
Junior Member
Thanks Meter 2
Posts: 16
Join Date: Jun 2011
Location: Košice
I trust sandisk more than anything, but this case was just coincidence. My problem was resolved, when I downgraded back to 4.2.2 stock and then I could do what I wanted, currently I have slimkat again and almost 24hours no unmounts
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes