Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,702 Members 45,522 Now Online
XDA Developers Android and Mobile Development Forum

No working rom | Backup not working | Download mode is screwed | Just got TWRP help!

Tip us?
 
bender_007
Old
#11  
bender_007's Avatar
Senior Member
Thanks Meter 1,439
Posts: 1,995
Join Date: Dec 2010

 
DONATE TO ME
Quote:
Originally Posted by Slashkun View Post
Yup its 2.7. Should i wipe then try adb push without restoring? (ill have to wait and give it a go on my lunch break) and i have CM11 to install which i have been trying to push using adb but i either get protocol failure and the phone is restarting or it still says read-only file system. Do you think just wiping all except internal and doing a factory reset will help me get past the whole read only file system issue?


lets say adb is in c:\adb


start, cmd (you run the cmd)


cd c:\adb

(copy your rom also somewhere with short path, let's say c:\adb\rom.zip)

adb push rom.zip /sdcard/rom.zip

or

adb push c:\adb\rom.zip /sdcard/rom.zip


adb sideload doesn't have to be enabled
 
Slashkun
Old
#12  
Junior Member - OP
Thanks Meter 0
Posts: 11
Join Date: Aug 2014
Quote:
Originally Posted by bender_007 View Post
lets say adb is in c:\adb


start, cmd (you run the cmd)


cd c:\adb

(copy your rom also somewhere with short path, let's say c:\adb\rom.zip)

adb push rom.zip /sdcard/rom.zip

or

adb push c:\adb\rom.zip /sdcard/rom.zip


adb sideload doesn't have to be enabled
Thanks for your continued assistance, however its still showing up as as a read only file system in cmd and thus it cannot copy. Do you have any other ideas? I have tried adb remount and it is still coming up with the read only error
 
wulsic
Old
#13  
wulsic's Avatar
Recognized Contributor
Thanks Meter 715
Posts: 969
Join Date: Aug 2013
Location: Nijmegen
The only thing i can think of is to use an microsdreader like meenova and put a rom on the microsd and put it in your phone but i dont know or your twrp supports otg.
Devices History
Htc Elf-Htc Google Nexus One-LG Optimus 2X-Samsung Galaxy S2-LG Nexus4

"Simplicity is the ultimate sophistication."
"The greatest ideas are the simplest." William Golding
"Simplicity is the art of maximizing the amount of work not done." - Agile Manifesto
"Simplicity is the way a human/developer should think to easily solve problems." - Wulsic

My Work So far
 
bender_007
Old
#14  
bender_007's Avatar
Senior Member
Thanks Meter 1,439
Posts: 1,995
Join Date: Dec 2010

 
DONATE TO ME
Quote:
Originally Posted by Slashkun View Post
Thanks for your continued assistance, however its still showing up as as a read only file system in cmd and thus it cannot copy. Do you have any other ideas? I have tried adb remount and it is still coming up with the read only error
Let me try to assist you when I get home.
 
Slashkun
Old
#15  
Junior Member - OP
Thanks Meter 0
Posts: 11
Join Date: Aug 2014
Quote:
Originally Posted by bender_007 View Post
Let me try to assist you when I get home.
Thanks so much for taking the time out to help me, this is way above my comfort zone

Quote:
Originally Posted by wulsic View Post
The only thing i can think of is to use an microsdreader like meenova and put a rom on the microsd and put it in your phone but i dont know or your twrp supports otg.
I have an OTG cable and it is there as an option under TWRP and i tried putting the roms on my 32gb stick and plugged it into the phone using the OTG cable however when i clicked mount OTG it just stalled for a bit and the option was never ticked, also looking through file manager when the cable was connected i did not see anything or the blue light on my usb stick illuminate. If i was doing it wrong please let me know though
 
bender_007
Old
#16  
bender_007's Avatar
Senior Member
Thanks Meter 1,439
Posts: 1,995
Join Date: Dec 2010

 
DONATE TO ME
Quote:
Originally Posted by Slashkun View Post
Thanks so much for taking the time out to help me, this is way above my comfort zone



I have an OTG cable and it is there as an option under TWRP and i tried putting the roms on my 32gb stick and plugged it into the phone using the OTG cable however when i clicked mount OTG it just stalled for a bit and the option was never ticked, also looking through file manager when the cable was connected i did not see anything or the blue light on my usb stick illuminate. If i was doing it wrong please let me know though
-p m


@usb - try formatting it through windows once again. I've also had some issues with my usb stick.
 
Slashkun
Old
#17  
Junior Member - OP
Thanks Meter 0
Posts: 11
Join Date: Aug 2014
Just thought i would throw out and update to see if it helps you guys troubleshoot.

After doing an advanced wipe when i use the power off through TWRP it mentioned that i have no SU installed and asks me if i wish to install it. I click yes and it does something quickly then my phone restarts (so not sure if it worked or not) however every time i try and do and adb push to my device now it just comes up with protocol failure and restarts the phone. Just to note when i do a restore to the non-working backup i have when i try and turn it off using that it does not prompt that i do not have SU.

So i hope this helps in some way, nut sure if getting these protocol failure errors is better then the read only errors i was getting but the fact that it keeps restarting my phone does not seem promising when i do this.
 
wulsic
Old
(Last edited by wulsic; 20th August 2014 at 08:46 PM.)
#18  
wulsic's Avatar
Recognized Contributor
Thanks Meter 715
Posts: 969
Join Date: Aug 2013
Location: Nijmegen
Quote:
Originally Posted by Slashkun View Post
Just thought i would throw out and update to see if it helps you guys troubleshoot.

After doing an advanced wipe when i use the power off through TWRP it mentioned that i have no SU installed and asks me if i wish to install it. I click yes and it does something quickly then my phone restarts (so not sure if it worked or not) however every time i try and do and adb push to my device now it just comes up with protocol failure and restarts the phone. Just to note when i do a restore to the non-working backup i have when i try and turn it off using that it does not prompt that i do not have SU.

So i hope this helps in some way, nut sure if getting these protocol failure errors is better then the read only errors i was getting but the fact that it keeps restarting my phone does not seem promising when i do this.
Well i guess you now have SU but the best thing to do is try to update the SU.
Try to Enable Usb debugging if it wasn't on yet. (I never had your error)

And also try to execute this when pushing a rom:
Code:
adb /kill-server
adb usb
adb push (romname) /sdcard

Or

adb push (romname)  /storage/sdcard0
I don't know really about the last part anymore with adb pushing or these sdcard locations I said are right. The last time I used it was when i still had my phone :/
I hope this could fix your problem when you maybe accidently formatted your internal storage. If my sdcard locations aren't right could you correct me then? so people who also have this issue can fix it easily.
Thankyou
Devices History
Htc Elf-Htc Google Nexus One-LG Optimus 2X-Samsung Galaxy S2-LG Nexus4

"Simplicity is the ultimate sophistication."
"The greatest ideas are the simplest." William Golding
"Simplicity is the art of maximizing the amount of work not done." - Agile Manifesto
"Simplicity is the way a human/developer should think to easily solve problems." - Wulsic

My Work So far

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes