Post Reply

[Q] [SOLVED] ATT G2 (d800) KK Modem - Outgoing Texts get Stuck

OP blastagator

28th August 2014, 10:05 PM   |  #1  
OP Senior Member
Flag Kissimmee
Thanks Meter: 141
 
205 posts
Join Date:Joined: Dec 2012
Donate to Me
More
I have tried several different KK ROMs that use the KK radio. Everytime I use the KK radio, my outgoing text messages occasionally get stuck. It'll show the sending area but will take 2-3 minutes to send, then go back to normal. This occurs randomly but with enough frequency it is VERY annoying.

Flashing the old modem to the KK ROM fixed the text sending issues but, of course, breaks many sensors. Anyone else experience this? Like I said, several different ROMs have been tried.

I have tried stock messaging apps as well as GoSMS. All have the same issue. I am using the ATT "phone" APN and all settings are correct.

Also oddly, I'll still receive incoming messages while outgoing is stuck.

Any thoughts?


Possible Solution: http://forum.xda-developers.com/show...61&postcount=5

HUGE Thank You to forum member dr87!
Last edited by blastagator; 2nd September 2014 at 01:09 AM.
29th August 2014, 03:25 AM   |  #2  
Senior Member
Thanks Meter: 740
 
1,793 posts
Join Date:Joined: Sep 2010
Quote:
Originally Posted by blastagator

I have tried several different KK ROMs that use the KK radio. Everytime I use the KK radio, my outgoing text messages occasionally get stuck. It'll show the sending area but will take 2-3 minutes to send, then go back to normal. This occurs randomly but with enough frequency it is VERY annoying.

Flashing the old modem to the KK ROM fixed the text sending issues but, of course, breaks many sensors. Anyone else experience this? Like I said, several different ROMs have been tried.

I have tried stock messaging apps as well as GoSMS. All have the same issue. I am using the ATT "phone" APN and all settings are correct.

Also oddly, I'll still receive incoming messages while outgoing is stuck.

Any thoughts?

I have the same behavior and now after reading your post it does remind me that my issue with this started when I flashed the KK baseband too. I had forgotten about that so never correlated the two together.
Last edited by EniGmA1987; 31st August 2014 at 04:40 AM.
29th August 2014, 01:03 PM   |  #3  
daraj's Avatar
Senior Member
Flag Florida, USA
Thanks Meter: 168
 
1,591 posts
Join Date:Joined: Jun 2007
Donate to Me
I have the same issue on the stock unrooted D800 ROM. Seems bigger than I thought. I wonder if It has something to do with the selected APN.
29th August 2014, 05:58 PM   |  #4  
OP Senior Member
Flag Kissimmee
Thanks Meter: 141
 
205 posts
Join Date:Joined: Dec 2012
Donate to Me
More
Quote:
Originally Posted by daraj

I have the same issue on the stock unrooted D800 ROM. Seems bigger than I thought. I wonder if It has something to do with the selected APN.

No other apn reliably gives me LTE.

However, I would think since they were able to patch the KK modem to support aosp sensor setup, that there would be a way to patch the old modem to work with the KK sensor setup.
31st August 2014, 06:24 AM   |  #5  
OP Senior Member
Flag Kissimmee
Thanks Meter: 141
 
205 posts
Join Date:Joined: Dec 2012
Donate to Me
More
Solved?
So with the AMAZING help of awesome xda member dr87, I created a patched KK modem. This modem file is the KK modem patched to use the 10d radio.

This is for d800 only.

I just created it tonight and flashed it. All sensors seem to be working and I have service. Only time will tell if this fixes the SMS issue. The baseband in my software menu did downgrade to the 10d version.

If anyone else wants to try, flash at your own risk. If this solves my problem I'll probably toss up a threat in the d800 forum.

Good luck!

For links, go to the thread below.
(For people unfamiliar with Google Drive, click the download button at the top to download the flashable zip.)


Also see, this thread I started:
http://forum.xda-developers.com/att-...radio-t2863727
Last edited by blastagator; 2nd September 2014 at 01:53 AM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in G2 Q&A, Help & Troubleshooting by ThreadRank