Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Adb not recognizing device on linux

OP Tectas

9th July 2014, 09:42 AM   |  #1  
Tectas's Avatar
OP Senior Member
Thanks Meter: 2,734
 
3,244 posts
Join Date:Joined: Jul 2011
Donate to Me
More
Did anyone manage to get adb recognize the g3 on Linux and if how?
I'm using ubuntu gnome 14.04, udev rules are set up (including the 1004 vendor id). The device probably shows up at dmesg, but adb doesn't recognize it, also checked if Windows (as much as i hate it) works and there adb shows the device.
Mtp is working fine, just debugging doesn't, even the pop up to trust the pc isn't showing up.

Gesendet von meinem LG-D855 mit Tapatalk

Edit: I also tired to add the line
Code:
0x1004
to the adb_usb.ini within .android, but it didn't work out.

Edit2:
I've now also tried to add the udev rules with the proper product ids, still no sucess ...
Last edited by Tectas; 9th July 2014 at 01:17 PM.
9th July 2014, 04:21 PM   |  #2  
anod's Avatar
Member
Thanks Meter: 5
 
86 posts
Join Date:Joined: Feb 2008
More
Try in PTP mode, it worked for me in OS X
The Following 4 Users Say Thank You to anod For This Useful Post: [ View ]
9th July 2014, 05:01 PM   |  #3  
Tectas's Avatar
OP Senior Member
Thanks Meter: 2,734
 
3,244 posts
Join Date:Joined: Jul 2011
Donate to Me
More
Quote:
Originally Posted by anod

Try in PTP mode, it worked for me in OS X

Damn it, why haven't i thought of that, tinkered around at the system, but missed that, works now, thanks
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes