Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,143 Members 51,897 Now Online
XDA Developers Android and Mobile Development Forum

Adb not recognizing device on linux

Tip us?
 
Tectas
Old
(Last edited by Tectas; 9th July 2014 at 12:17 PM.)
#1  
Tectas's Avatar
Senior Member - OP
Thanks Meter 1941
Posts: 2,825
Join Date: Jul 2011
Location: Graz

 
DONATE TO ME
Default Adb not recognizing device on linux

Did anyone manage to get adb recognize the g3 on Linux and if how?
I'm using ubuntu gnome 14.04, udev rules are set up (including the 1004 vendor id). The device probably shows up at dmesg, but adb doesn't recognize it, also checked if Windows (as much as i hate it) works and there adb shows the device.
Mtp is working fine, just debugging doesn't, even the pop up to trust the pc isn't showing up.

Gesendet von meinem LG-D855 mit Tapatalk

Edit: I also tired to add the line
Code:
Select Code
0x1004
to the adb_usb.ini within .android, but it didn't work out.

Edit2:
I've now also tried to add the udev rules with the proper product ids, still no sucess ...

Current Device
LG G3 (D855 16 gb)


ROM
Stock (V10e-232-01) rooted


For ROM developers
BuildBox (Kitchen/Ota App [Open Source]) set your device free

 
anod
Old
#2  
anod's Avatar
Member
Thanks Meter 3
Posts: 86
Join Date: Feb 2008
Try in PTP mode, it worked for me in OS X
LG G3 16gb

Galaxy S5 <- LG G2 <- Note II <- Galaxy Nexus <- Galaxy S1 <- Nexus One <- HTC Dream
The Following 2 Users Say Thank You to anod For This Useful Post: [ Click to Expand ]
 
Tectas
Old
#3  
Tectas's Avatar
Senior Member - OP
Thanks Meter 1941
Posts: 2,825
Join Date: Jul 2011
Location: Graz

 
DONATE TO ME
Quote:
Originally Posted by anod View Post
Try in PTP mode, it worked for me in OS X
Damn it, why haven't i thought of that, tinkered around at the system, but missed that, works now, thanks

Current Device
LG G3 (D855 16 gb)


ROM
Stock (V10e-232-01) rooted


For ROM developers
BuildBox (Kitchen/Ota App [Open Source]) set your device free

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes