Default [Q] "Answer Me" Help

Liked the idea of using "Answer Me" feature but quickly found out it doesn't work for me. I have all the check boxes unmarked in the settings, however the calls still auto answer after 5 secs.

Help, how do you stop this from happening?

Thanks,
Paul