Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,233 Members 50,843 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Bluetooth A2DP issue with Car Stereo

Tip us?
 
Vexamus
Old
#1  
Junior Member - OP
Thanks Meter 1
Posts: 27
Join Date: Nov 2007
Audio [Q] Bluetooth A2DP issue with Car Stereo

Ok, so here's the deal. I have a rooted T-mo G3 (D851) on a stock rom, out of the box it's been awesome to use with my Pioneer AVH-X2600BT head unit in my scooby. I was messing around with themes a short while ago and then the bluetooth stopped working intermittently. From what I can tell the mix-rate of the A2DP stream changes from 44k to 3hz and all you hear are beeps at multiple amplitudes. The beeps are playing out of the buffer in the head unit until it empties then it resets the connection to the phone. It still plays out these beeps until it's empty even if I disconnect the phone from the head unit.

I don't have this problem with two other iPhones. And previous to my screwing around, it'd work flawlessly since a bought it (launch day.)

Could I have screwed up a mixrate setting someplace? I do have a custom mixer xml for boosting headphone port and speaker audio but I never touched the settings for the bluetooth driver.

This behavior is intermittent and it matters very little what content I'm playing through it. I do notice that when this is happening, no metadata or control is capable through AVRCP either. (i.e. Pandora app can't connect to the phone, no album art, etc)

Sometimes it'll stop doing it and play normally for the rest of the session (drive) after a few minutes and everything is normal. Sometimes it doesn't do it at all and sometimes I can't get it work normally at all.

Here's a video showing the behavior:

http://youtu.be/qYuuTG01x1E
 
jtambis6
Old
(Last edited by jtambis6; 1st September 2014 at 03:42 AM.) Reason: Update!
#2  
Member
Thanks Meter 10
Posts: 86
Join Date: Dec 2011
Location: Jakarta
Reset your Bluetooth on your headunit and pair it again with all your bluetooth devices.

I had a similar problem with my LG G3 and my Pioneer AVH-8500 where my Pioneer will not recognize my LG G3 anymore but recognizes my Note 3.

I fixed the problem by resetting my Bluetooth on my Pioneer and had to pair all my devices back to it again.

You will have to look into your Pioneer manual on how to reset your bluetooth.

Edit: I just remembered something.

Did you happen to update or change your firmware.

Some KitKat firmwares are missing the Bluetooth Metadata and will not function properly.
HTC Evo 4G (used as alarm clock)
HTC Evo 3D (used to show-off its 3D capability)
Samsung Galaxy Nexus (collecting dust)
Samsung Galaxy Note 2 N7100: Back to stock Jelly Bean 4.1.2 (handed down to my brother)
Samsung Galaxy S4 i9500: Omega v20 :Perseus Alpha v15.2
Samsung Galaxy Note 3 SM-N9000: VN-Rom v14 Kernel: Halaszk 16
Sony Xperia Z2 (Sold to Mom)
LG G3 D855 32GB Rooted/Stock Rom
The Following User Says Thank You to jtambis6 For This Useful Post: [ Click to Expand ]
 
ad78
Old
#3  
Senior Member
Thanks Meter 60
Posts: 460
Join Date: Mar 2011
Location: Connecticut
Use autoaudio download it from playstore. This fixes my problem on metadata
 
Vexamus
Old
#4  
Junior Member - OP
Thanks Meter 1
Posts: 27
Join Date: Nov 2007
Hey thanks guys.

I reflashed the bt radio in my head unit and the problem so far has seemed to go away. Metadata and everything works again.

I appreciate the heads up from another pioneer user.
Tags
a2dp, bluetooth, car audio
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes