Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Help: G3 doesn't power on - Only blue/green notification light blinks :(

OP ashkaboos

7th October 2014, 06:22 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jun 2010
The G3 just dropped down on the floor with the circle case. Then It was working some minutes apparently with no problem, until I myself turn the phone off and restart it. Then the device just didn't turn on. The only thing is that the screen is black and the led notification blinking green and blue
when i connect the charger, the red led blinks once and then disappears, then after 30 seconds the red led appears which apparently shows that the phone is charging the battery. Also When I connect the phone to the PC, a sound of connection is heard from PC but the PC doesn't complete the device recognition process as no new device is found.
I tried to make a hard reset, but nothing happens when I press the power and volume down keys. Tried some other tricks with the battery and the hard keys on the phone but no result at all, as the same story just repeats. Does anybody have a solution for the problem? This devise is the only android device I have
Last edited by ashkaboos; 7th October 2014 at 09:28 PM.
8th October 2014, 06:19 AM   |  #2  
OP Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jun 2010
Post Help
Please Help
8th October 2014, 09:08 PM   |  #3  
Member
Flag Eindhoven
Thanks Meter: 14
 
60 posts
Join Date:Joined: Aug 2014
More
Quote:
Originally Posted by ashkaboos

The G3 just dropped down on the floor with the circle case. Then It was working some minutes apparently with no problem, until I myself turn the phone off and restart it. Then the device just didn't turn on. The only thing is that the screen is black and the led notification blinking green and blue
when i connect the charger, the red led blinks once and then disappears, then after 30 seconds the red led appears which apparently shows that the phone is charging the battery. Also When I connect the phone to the PC, a sound of connection is heard from PC but the PC doesn't complete the device recognition process as no new device is found.
I tried to make a hard reset, but nothing happens when I press the power and volume down keys. Tried some other tricks with the battery and the hard keys on the phone but no result at all, as the same story just repeats. Does anybody have a solution for the problem? This devise is the only android device I have

Did you do anything else after/during the time that the phone was off? And is there no possibility that you cracked the LCD digitizer? I mean it might sound strange but this is what I had with my old phone. I dropped it, nothing serious but then I put it in my pocket and upon taking it out I noticed the screen not turning on. As stated above, my digitizer was broken and multiple people told me that the digitizer had a small crack which I didn't notice, then when I put it in my pocket I put too much pressure on the digitizer cracking it. The LED-light did work though, and this sounds very similar so my advise going to the store and asking wether they know what the problem might be.
(Hopefully this was helpfull hehe)
The Following User Says Thank You to Neorpowa For This Useful Post: [ View ]
9th October 2014, 12:39 AM   |  #4  
Senior Member
Flag Jacksonville
Thanks Meter: 68
 
181 posts
Join Date:Joined: Jul 2007
More
Quote:
Originally Posted by ashkaboos

Please Help

If you Don't see the LG splash screen when pressing the power button it seems like a screen or digitizer problem for sure.

BUT;

after you try turning it "on" let it sit a few minutes and see if you can call your self or send a text to see if it makes noise vibrates etc. to confirm a screen problem.

OR

Also you can try putting it into download mode.
Battery pull (don't turn on)
plug USB into phone but not computer
Hold volume down AND then plug usb into computer

if this comes up to a pic of something on the phone it will be software related. to get out of this mode you can do a battery pull.

Remember to always read up on topics and things you are doing. There are guides here on XDA to help you out.

Hope you get your phone working
The Following User Says Thank You to Tweakecho For This Useful Post: [ View ]
9th October 2014, 01:43 AM   |  #5  
OP Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jun 2010
Quote:
Originally Posted by Neorpowa

Did you do anything else after/during the time that the phone was off? And is there no possibility that you cracked the LCD digitizer? I mean it might sound strange but this is what I had with my old phone. I dropped it, nothing serious but then I put it in my pocket and upon taking it out I noticed the screen not turning on. As stated above, my digitizer was broken and multiple people told me that the digitizer had a small crack which I didn't notice, then when I put it in my pocket I put too much pressure on the digitizer cracking it. The LED-light did work though, and this sounds very similar so my advise going to the store and asking wether they know what the problem might be.
(Hopefully this was helpfull hehe)

I didn't do anything special after/during the time the phone was off. I checked the screen very carefully under a lamp. No particular sign of crack. Thank you very much for sharing ur experience.
9th October 2014, 01:48 AM   |  #6  
OP Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jun 2010
Quote:
Originally Posted by Tweakecho

If you Don't see the LG splash screen when pressing the power button it seems like a screen or digitizer problem for sure.

BUT;

after you try turning it "on" let it sit a few minutes and see if you can call your self or send a text to see if it makes noise vibrates etc. to confirm a screen problem.

OR

Also you can try putting it into download mode.
Battery pull (don't turn on)
plug USB into phone but not computer
Hold volume down AND then plug usb into computer

if this comes up to a pic of something on the phone it will be software related. to get out of this mode you can do a battery pull.

Remember to always read up on topics and things you are doing. There are guides here on XDA to help you out.

Hope you get your phone working

I tried to put it into download mode, but no result at all as no connection could also be made between the phone and PC. Moreover, I tried to make a text/call, but nothing is received by the phone. Thank you very much for ur suggestions.
9th October 2014, 02:01 PM   |  #7  
suljo94's Avatar
Senior Member
Flag Antwerpen
Thanks Meter: 432
 
1,297 posts
Join Date:Joined: Nov 2013
More
Quote:
Originally Posted by ashkaboos


I tried to put it into download mode, but no result at all as no connection could also be made between the phone and PC. Moreover, I tried to make a text/call, but nothing is received by the phone. Thank you very much for ur suggestions.

Seems like the drop damaged the memory and the phone can't reload it, you will have to bring it in
The Following User Says Thank You to suljo94 For This Useful Post: [ View ]
9th October 2014, 04:46 PM   |  #8  
Member
Flag Eindhoven
Thanks Meter: 14
 
60 posts
Join Date:Joined: Aug 2014
More
Quote:
Originally Posted by suljo94

Seems like the drop damaged the memory and the phone can't reload it, you will have to bring it in

Yeah that's plausible ! I'd bring it in too

Hope you fix your phone fast
The Following User Says Thank You to Neorpowa For This Useful Post: [ View ]
9th October 2014, 08:26 PM   |  #9  
OP Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Jun 2010
Yeah... Probably it's a hardware problem. Someone who checked the phone in order to fix it, said that the problem had been with the device board. Even though I was satisfied with the phone, I have found out that the G3 is a sensitive device, as the height of the table from which it dropped down wasn't too much. So always take care of your G3 phone.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes