FORUMS

Xiaomi Sold 34.7 Million Phones In 6 Months

2015 has been a phenomenal year for Xiaomi so far. With a stellar rise in 2014, 2015 saw … more

Sprint Reacts To Jab From T-Mobile

America’s cellular network space has always been a battle of the big four: Verizon, AT&T, … more

Floating Apps with Rovers – XDA App Review

There are a lot of great launchers to help customize your phone. Some Launchers allow … more

What Features Do You Look for in a Gallery App?

With so many different options to choose from, finding the right Gallery app may be a … more

Mic Doesn't Work When Speaker On

1,704 posts
Thanks Meter: 179
 
By lexluthor, Senior Member on 23rd July 2014, 10:48 PM
Post Reply Subscribe to Thread Email Thread
Just got my Verizon G3 yesterday. I have it rooted and have Xposed and G3 Tweaksbox. I don't think I froze anything that would have to do with the mic/speakerphone.

When my speaker is on, my mic doesn't work.

Mic works fine otherwise, so it can't be a hardware issue.

Any ideas?
 
 
24th July 2014, 01:24 AM |#2  
OP Senior Member
Thanks Meter: 179
 
More
I disabled all xposed modules and unfroze all apps and same thing.

Can someone confirm they don't have this issue on a Verizon phone?

I really don't want to factory reset already.
24th July 2014, 03:30 AM |#3  
OP Senior Member
Thanks Meter: 179
 
More
Could someone just test this out and let me know if you don't have the issue?

Just make a call, turn on the speaker and see if the party on the other end can hear you talking.

Be best if it's someone with a Verizon phone.

If it works for someone else on Verizon, I guess I'll go with the factory reset. The phone has only been out a few days, I guess it's possible it's a bug and I'm just the first person who noticed it, but I doubt it.
24th July 2014, 05:12 AM |#4  
OP Senior Member
Thanks Meter: 179
 
More
I did a factory reset and it's still not working.

I did take off my case and now there's some audio, but it's all a low static. I call a vm I have and start talking with speaker off and it's fine, then I turn speaker on and I get all static and hissing and can't hear myself at all.

I don't see how it could be hardware, but I guess it's possible. Sure seems like a system bug, but someone in the Verizon forum reported it's working, so I guess not.
24th July 2014, 01:00 PM |#5  
OP Senior Member
Thanks Meter: 179
 
More
Flashed back to factory image and same problem.

I guess it's my hardware.
24th July 2014, 08:53 PM |#6  
OP Senior Member
Thanks Meter: 179
 
More
Replaced phone today and all is good. I guess defective hardware.

It must have a different mic for when using speakerphone vs when not.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes