Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,758 Members 46,454 Now Online
XDA Developers Android and Mobile Development Forum

Mobile Data Stops Working - Requires Reboot

Tip us?
 
objektive_1
Old
#11  
Member
Thanks Meter 7
Posts: 65
Join Date: Feb 2012
Quote:
Originally Posted by biglilsteve View Post
I never noticed the issue the first day. Give it couple days and see how things go for you.
i've been manhandling the phone all day. no dropped data or calls at all besides the usual dead zones. I'm in Northern NJ so service is pretty solid up here.
 
paulnash
Old
#12  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Aug 2014
Default same

I'm in singapore - had same issue. No 3G/4G data. Calls ok, wifi ok. A reboot fixes the issue.
 
deadlyheart4u
Old
#13  
deadlyheart4u's Avatar
Senior Member
Thanks Meter 61
Posts: 471
Join Date: Apr 2008
Location: Kolkata

 
DONATE TO ME
Yes same happens here in india
Cheers,
Aditya Bhimrajka

CEO, SimTechnos.in
Web|Apps|Seo|Mobile
-----------------------------
 
Smithfolk4
Old
#14  
Junior Member
Thanks Meter 1
Posts: 11
Join Date: Jul 2014
Location: Rockville, MD
Default Not On G3, But Previous Phones

I had this happen occasionally on a Droid RAZR., Always assumed it was something between the phone and the network. It only happened every couple months and a reboot always fixed the issue. Haven't had it happen on the G3. Live near Washington DC. Pretty good coverage.
 
JustLok
Old
#15  
JustLok's Avatar
Senior Member
Thanks Meter 52
Posts: 223
Join Date: Jan 2010
This is seen on the T-Mobile D851 variant as well.

One way that fixes the data issue is to enable Airplane Mode and then disable it (immediate enable and then disable does it, no wait time for a reset). Fixes the loss of the data connection with no reboot required.

You can try that and see if works as well.
 
dex.
Old
#16  
Senior Member
Thanks Meter 21
Posts: 107
Join Date: Aug 2010
Default Fast Dormancy?

I wonder whether disabling fast dormancy would resolve the issue? If your mobile data provider does not implement fast dormancy then it needs to be disabled on the phone.

I get the fast dormancy option via the hidden menu (3845#*855# on my D855, replace with your model number), then Settings, then Fast Dormancy. Needs a reboot to apply.

You will need to Google if your mobile provider supports fast dormancy.

Worth a try.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Sony PS4 Remote Play Ported to All Android Devices

Im pretty sure that every informed gamer out there perked their ears up when Sony came out … more

Change Your Samsung Galaxy S2’s Dialer Background in Real Time

As with anything, if youve looked at something long enough, things can … more

Increase Your Multitasking Workflow with C-Floating Windows

Technology has put life on the fast track. Lazy, relaxed days have turned into … more

Compile Your Own Kernel From Source with Comprehensive Tutorial

One glance at any developer section of any device forum on XDA and youll find … more