Mozilla Ditches Google, Makes Yahoo Default Search Engine

Mozilla and Google have had a long-standing relationship of about 10 years. Google … more

Learn More About Linux with Linux Man Pages

Linux is quite a powerful and very configurable operating system. Thanks to some user-friendly … more

Detect, Avoid IMSI-Catcher Attacks with Android IMSI-Catcher Detector

Privacy is always an important topic, as well as a delicate one to … more

Materialized LeanDroid Fights Your Poor Battery Life

Battery life has always been one of the biggest problems facing most Android devices. … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[GUIDE] HOW TO Enable Wi-Fi Tether on stock Kit Kat 4.4.2

OP radiohead7778580

25th August 2014, 04:43 AM   |  #1  
radiohead7778580's Avatar
OP Senior Member
Flag Chicago
Thanks Meter: 142
 
225 posts
Join Date:Joined: Apr 2010
Donate to Me
More
Here is a Guide to get Hotspot Working With The Stock App (tested with T-Mobile)

If you have unlimited data you will have unlimited tethering

1) You need to be rooted and a build.prop editor (root explorer)

Inside your build.prop find:
net.tethering.noprovisioning=true
(this is near the bottom)

Set this to false
Save then reboot.

Props for step 1 to androidguy1991


2) Change APN Settings
Name: T-MOBILE IPv4
APN: fast.t-mobile.com
Proxy: [blank]
Port: [blank]
Username: [blank]
Password: [blank]
MMSC: http://mms.msg.eng.t-mobile.com/mms/wapenc
MMS Proxy: [blank]
MMS Port: [blank]
MCC: 310
MNC: 260
Auth Type: [blank]
APN Type: default,supl,mms,dun
APN Protocol: IPv4
MVNO Type: [blank]
MVNO Value: [blank]

3) Edit Settings.db File

Download SQlite editor app from G.Play (pay for it few bucks)

Open "settings.db" then "global" and under "tether_dun_required" change 1 to 0
"settings.db" is under the path: /data/data/com.android.providers.settings/databases"

4) Making Sure it Stick After Reboot
Download My Script http://d-h.st/riT (remember where you saved it to)
Download SManager From G.Play
Open SManager
Find the Tether Script You Downloaded
Click on it and select FAV,SU,BOOT and Save

Reboot Phone Make sure the script runs after phone reboots you might get SU Prompt, Grant it permission

5) ENJOY!!!!
The Following 4 Users Say Thank You to radiohead7778580 For This Useful Post: [ View ]
20th September 2014, 08:52 PM   |  #2  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: May 2012
Unhappy Sqlite Error
I did everything you said, but the values return to normal once the phone is rebooted

I have root, SU, and unlocked bootloader

I checked the script that you made and I ran it on Smanager, it shows that Sqlite3 is not found,

how can I fix this?
20th September 2014, 10:21 PM   |  #3  
radiohead7778580's Avatar
OP Senior Member
Flag Chicago
Thanks Meter: 142
 
225 posts
Join Date:Joined: Apr 2010
Donate to Me
More
Quote:
Originally Posted by forzaditalia

I did everything you said, but the values return to normal once the phone is rebooted

I have root, SU, and unlocked bootloader

I checked the script that you made and I ran it on Smanager, it shows that Sqlite3 is not found,

how can I fix this?

download this sqlite installer and run it you should be all good to go

https://play.google.com/store/apps/d...3forroot&hl=en
21st September 2014, 12:45 AM   |  #4  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: May 2012
provisioning
thanks a lot. however, the net.tethering.provisioning value is always reset to True when I try to use the stock app for tethering or use only the USB tether in the settings menu
is there a way to make this permanent. the prop.builder has already super user granted. it saves yhe value. but then like i said, if i use any of the stock tether programs is reset to True.
21st September 2014, 08:00 AM   |  #5  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: May 2011
Trying to get this to work for MetroPCS
I'm attempting to get this to work on MetroPCS and I've made the change in the build.prop as well as the change in the settings.db file. I'm guessing that My APN settings will be different since I'm aiming to get this working on Metro. When I reboot my build.prop setting change is persisted. So, I know that portion at least worked.

forzaditalia <-- I tried a couple of different build.prop editors and had trouble keeping the change after reboot. You might want to consider trying another build.prop editor. The one I finally got to work is called "PropEditor". I dont know if it's the best, but it worked for me. Just thought I would share that.

radiohead7778580 <-- I tried to run that script you put up in script manager but I get an error. Also, when I reboot the settings.db change has reverted. So, I know that script is having an issue. It appears to not be able to find SQLite. It says system/xbin/sqlite3: not found. Where might this be installed that I can point it to.

Also, is there a specific change to the APN settings that is required? I noticed that in the T-Mobile changes you suggested there is an APN type of DUN in there that my current APN settings do not have. Do I need to add this possibly? I've seen two different sets of APN settings for Metro from other sources online. What set should I be using

Mine are currently set as:
apn carrier="MetroPCS"
mcc="310"
mnc="260"
extraid="6D"
apn="fast.metropcs.com"
user=""
password=""
authtype="0"
server=""
proxy=""
port=""
mmsc="metropcs.mmsmvno.com/mms/wapenc" [NOTE: Had to remove http from the beginning to post since I'm a newb]
mmsproxy=""
mmsport=""
type="default,mms,supl"
preferapp=""

And I've also seen these settings posted:
Name: US – MetroPCS Web
APN: metropcs
Proxy:
Port:
Username:
Password:
Server:
MMSC:
MMS Proxy:
MMS Port:
MMS Protocol: WAP 2.0
MCC: 310
MNC: 16
Authentication Type: PAP
APN Type: default, supl
<p>PXT Messaging MMS:
Name: US – MetroPCS MMS
APN: metropcs
Proxy:
Port:
Username:
Password:
Server:
MMSC: mms.metropcs.net:3128/mmsc [NOTE: Had to remove http from the beginning to post since I'm a newb]
MMS Proxy: proxy.metropcs.net
MMS Port: 3128
MMS Protocol: WAP 2.0
MCC: 310
MNC: 16
Authentication Type: PAP
APN Type: mms

---------- Post added at 02:00 AM ---------- Previous post was at 01:44 AM ----------



Ok, I just noticed the post about the SQLite Installer for Root. That seems to have gotten that script executing properly. Also, that settings.db value is now being persisted after reboot. So, I'm wondering if getting the proper APN settings is all I have left to get this working. Currently, I get forwarded to this page when I connect to the Wifi offers.t-mobile.com/tethering/upsell.do?source=pcweb which tried to sell me on the service addon. I think maybe I will try and give that second set of APN settings a try and see if that helps at all.
Last edited by DeviousJohn; 21st September 2014 at 08:05 AM.
25th September 2014, 07:04 AM   |  #6  
Junior Member
Thanks Meter: 0
 
14 posts
Join Date:Joined: Apr 2011
Quote:
Originally Posted by radiohead7778580

4) Making Sure it Stick After Reboot
...
Click on it and select FAV,SU,BOOT and Save

Why is FAV necessary? Is it even necessary to keep Script Manager - SManager installed? Does it need to be running in the background?
15th November 2014, 11:47 AM   |  #7  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Aug 2014
is this method still working?

Anything easier or newer since this?

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes