Default [Q] Cant Flash V10f, v10i, v10p v20d on my Nitro LTE

My Phone is a Korean Based LG Phone LG-SU640. It was originally v10p. Build GRJ90 2.3.5I would like to root it so I tried rooting using the following guide.

SRS Root
Oneclick Root
Rooting by B1n4ry

and it all failed so I tried flashing using:
http://forum.xda-developers.com/show....php?t=1597488
http://forum.xda-developers.com/show....php?t=2044645

P930_UDT_v18f_04112012.exe - successful (but cannot use WIFI)

then in the instruction. I have to flash again to the ff after rooting
v10i = bootloop
v10f = bootloop
v10p = cannot flash - error on LG update software
v20d = cannot flash - error on LG update software

since I cannot use my phone using v10i,f,p, v20d, I am stuck at v18f which I cannot use WIFI.

I also tried directly flashing thru adb by sending the ff commands

adb shell
su
dd if=/sdcard/boot.img of=/dev/block/mmcblk0p8
dd if=/sdcard/firmware.img of=/dev/block/mmcblk0p1
dd if=/sdcard/baseband.img of=/dev/block/mmcblk0p14
dd if=/sdcard/system.img of=/dev/block/mmcblk0p27

but after, it says

error secure boot.
----
enter fastboot
enter fastboot
----
long time no see!

since I cannot use my phone using v10i,f,p, v20d, I am stuck at v18f which I cannot use WIFI.


Any help please