Official TWRP Recovery Lands on Micromax Canvas Magnus

With the recent release of Android One, Micromax and MediaTek released fully buildable … more

Update Overload: SuperSU Heavily Updated

There are apps and apps out there. Very few can reach the level of popularity required to stay at … more

Lollipop Leak Available for the Sprint Galaxy S5

Since the Android 5.0Lollipop’s official release not too long ago, we’ve seen … more

CPU Spy Gets an Android Lollipop Makeover

At some point in the distant past, you probably heard of CPU Spy for Android by XDARetired … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Device descriptor request failed

OP hoursenghong

28th July 2014, 08:06 AM   |  #1  
OP Member
Flag Phnom Penh
Thanks Meter: 4
 
97 posts
Join Date:Joined: Sep 2012
Donate to Me
More
So first of all I just want to say "it has nothing to do with preview for developers". That's first.
Back then when I was using Lumia black (8), things seem to be fine.
After updating to 8.1 using preview for developers, yeah I live it very much. But I don't know what happened to my device. I was able to sideload stuff like, you know, install paid app for free. But that was for a while. Now I'm not able to do that anymore. Whenever I connect my device to PC, it keeps on showing device decriptor request failed.
DONT SAY "TRY USING DIFFERENT CABLE OR USB SLOT". I did ask those IT guys about it, but they seem stupid (no offend). All they told me was this line I mention in DONT SAY.
I have 5cables in my house, 2laptops and 1desktop, all with Nokia sdk, with total of 15 USB slots. I tried it all and it's not working.
I wish someone in here can help me since google couldn't. Sorry for my English.
28th July 2014, 09:42 AM   |  #2  
dxdy's Avatar
Senior Member
Thanks Meter: 1,692
 
3,680 posts
Join Date:Joined: Apr 2008
Donate to Me
More
to sideload XAP files you need WP SDK 8, developer account (pay $19/year to Microsoft) and dev unlocked phone with WP SDK... work fine on my Lumia 920 with preview for developers...
28th July 2014, 10:44 AM   |  #3  
OP Member
Flag Phnom Penh
Thanks Meter: 4
 
97 posts
Join Date:Joined: Sep 2012
Donate to Me
More
Didn't I say I was able to do that? Yeah I can. But pc won't recognize my device.
28th July 2014, 02:10 PM   |  #4  
dxdy's Avatar
Senior Member
Thanks Meter: 1,692
 
3,680 posts
Join Date:Joined: Apr 2008
Donate to Me
More
Which Windows you have? Windows 8 or 8.1 x64 is recommended because WP SDK 8...

check solutions on Microsoft page: http://support.microsoft.com/kb/2749484

also try reinstall Nokia drivers, best to do this is to install Nokia Software Recovery Tool
http://download.fds-ncom.nokia.com/s...lInstaller.exe

also check Windows Update in Control Panel to update current windows drivers...
28th July 2014, 04:15 PM   |  #5  
OP Member
Flag Phnom Penh
Thanks Meter: 4
 
97 posts
Join Date:Joined: Sep 2012
Donate to Me
More
Quote:
Originally Posted by dxdy

Which Windows you have? Windows 8 or 8.1 x64 is recommended because WP SDK 8...

check solutions on Microsoft page: http://support.microsoft.com/kb/2749484

also try reinstall Nokia drivers, best to do this is to install Nokia Software Recovery Tool
http://download.fds-ncom.nokia.com/s...lInstaller.exe

also check Windows Update in Control Panel to update current windows drivers...

I swear to god, I have windows 8.1 64 bit, all on 2laptop and 1 desktop. All have Nokia Software Update and Nokia care suite thing. Maybe last month, or 20 days, I did side load amazing spider man 2 just fine. But today, it's not reading my phone. Again, I swear, I did not install or uninstall anything on both laptops and desktop. It just suddenly stops working. Or maybe it uninstalled itself from all 2 laptops and 1 desktop?
28th July 2014, 04:33 PM   |  #6  
dxdy's Avatar
Senior Member
Thanks Meter: 1,692
 
3,680 posts
Join Date:Joined: Apr 2008
Donate to Me
More
or maybe is hardware problem with USB connector on phone
28th July 2014, 04:46 PM   |  #7  
Senior Member
Flag Dallas, TX
Thanks Meter: 9
 
129 posts
Join Date:Joined: Sep 2010
More
Or an issue with the update. I was having all kinds of issues connecting to blue tooth devices after the update. A couple of hard resets and a fresh profile later and most of the kinks are worked out.

If all your computers and cords work, the only thing left is the device. It's either hardware or software, and the easiest thing to test is to put it into recovery mode and see if it detects it / can write to it.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes