Post Reply

[Q] Tricky brick question, stuck at charging screen, won't boot

OP jakiwar

25th August 2014, 07:28 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Mar 2012
Hi,
I recently helped a friend to change a broken digitizer glass screen on a Nokia Lumia 920 with RM-821. I ordered the new digitizer on ebay from china/hongkong so can't say anything about its functionality or possible compatibility issues.

When I started to change the digitizer the battery was very low. When I thought everything was done properly and the phone was put together again, and tried to start it, and nothing happened. I think I also tried a vol down+power button soft reset, and i remember i got some feedback from the vibrator but nothing from the screen. Well, I took it apart again and quickly discovered that the screen cable wasn't properly attached, so I attached it. (afterwards I saw somewhere that a low-battery soft-reset was a sure way to brick the phone...)

Next step, I've put the phone together and try to start it, nothing happens. Connect to charger, after some seconds a vibration, followed by the Nokia logo and then a screen with a flash and a cog-wheel (nothing animated). This is the state it is permanently stuck in. The only way to "start it" is to connect the charger and wait. If the charger is disconnected at the Nokia logo then it goes to the "no-battery"-icon and the powers off. At the flash-cogwheel it is possible to restart the phone by holding vol-down+power.

I let the charger be in for multiple hours, still the same thing. Took out the battery and charged it manually with external charger and some home-made wiring. That charger directly indicated that the battery was full with its indicator LED, but i still let it be for around an hour. Conclusion: battery is charged and most likely were charged in the phone.

I've tried to connect it through Nokia Software Updater for Retail 4.2.1, and the "my phone doesn't boot"-option doesn't find the phone after holding vol-down+power. (as described here http://www.wpcentral.com/suffering-s...dows-phone-fix and other places)

No connection with Nokia Care Suite 5.4.119 either, using method as described here http://forum.xda-developers.com/show...php?p=47195500

SUMMARY
Since connecting the charger starts the phone, some part of the usb must work. The screen apparently work, don't know about the digitizer obviously. Since it is possible to restart from "flash+cog-wheel"-screen the side buttons aren't dead. Since removing the charger at the "flash-cog-wheel" screen doesn't power off the phone the battery does in fact work.

Naturally I can't rule out that I managed to break something on the mainboard when I changed the digitizer, even though I don't think so.

Hope somebody can help!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes