Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,813,666 Members 39,873 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Moto E starts when power or usb cable connected

Tip us?
 
Ceriain
Old
(Last edited by Ceriain; 29th July 2014 at 01:30 AM.)
#1  
Junior Member - OP
Thanks Meter 5
Posts: 18
Join Date: Oct 2012
Question [Q] Moto E starts when power or usb cable connected

Hi guys,

Mother in law just picked one of these up (I'm setting it up, etc) and it seems to have an issue (or 2).

When I power it down while a usb, or power, cable is connected, it just boots straight back up.

When it is powered off and I connect a power cable, or connect usb to pc to power it, it boots up. No plain black battery charging screen.

Any ideas? .

btw. It's still fully stock rom, but with unlocked bootloader and rooted.

Last time I saw behaviour like this was with a crappy, cheap Chinese tablet.

TIA
 
magicw
Old
#2  
magicw's Avatar
Senior Member
Thanks Meter 88
Posts: 298
Join Date: Jan 2013
It's not a bug - it's a feature
currently mine: Moto E CM11 // GT-I9001 CM11
admin for: GT-I8190 (CM10.1 and CM11) and Moto E (rooted Stock)
The Following User Says Thank You to magicw For This Useful Post: [ Click to Expand ]
 
Ceriain
Old
(Last edited by Ceriain; 29th July 2014 at 04:01 PM.)
#3  
Junior Member - OP
Thanks Meter 5
Posts: 18
Join Date: Oct 2012
Quote:
Originally Posted by magicw View Post
It's not a bug - it's a feature
Seriously? Care to elaborate? Thanks for replying btw.

In my house are HTC One (M7), Moto G, Google Nexus 7 (2012), Tesco Hudl and a Galaxy Young; none of those do anything like this.

Edit: just tried a 'proper' power cable and it acted as expected (charging gif and not full boot), so it's a pc/usb connection that boots automatically. I think I see what you mean by "it's feature"; allows the phone to boot when connected to pc usb for fastboot and stuff, is that it?

Thanks again.
 
magicw
Old
#4  
magicw's Avatar
Senior Member
Thanks Meter 88
Posts: 298
Join Date: Jan 2013
I did not investigate in depth - but I also know rebooting behavior on my S3 minis. And, yes, possibly theres a kind of wakeup recognition on data line in USB connection.
If you google about this topic you will find it in the web on other devices also - but i did not find a handsome reason for why the manufacturers do let them behave like that.
currently mine: Moto E CM11 // GT-I9001 CM11
admin for: GT-I8190 (CM10.1 and CM11) and Moto E (rooted Stock)
The Following User Says Thank You to magicw For This Useful Post: [ Click to Expand ]
 
Ceriain
Old
#5  
Junior Member - OP
Thanks Meter 5
Posts: 18
Join Date: Oct 2012
Quote:
Originally Posted by magicw View Post
I did not investigate in depth - but I also know rebooting behavior on my S3 minis. And, yes, possibly theres a kind of wakeup recognition on data line in USB connection.
If you google about this topic you will find it in the web on other devices also - but i did not find a handsome reason for why the manufacturers do let them behave like that.
I'll do some more reading, but I'm okay with how it seems.

Most grateful for your assistance and input; thanks.

C.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes