Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Rooted XT1023, tried to install OTA update, stuck in reboot loop

OP hcsteve

26th September 2014, 06:30 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Sep 2014
Hoping someone can help me out with what was obviously a stupid mistake. I have a Moto E on which I installed TWRP and then SuperSU for root access. I got a notification about an OTA update to 4.4.4 and I stupidly accepted it. Now when my phone boots up, it goes into TWRP. If I tap the middle icon on the bottom, I can see the following console output:

Code:
Installing zip file '/cache/Blur_Version.21.12.34.condor_retuaws.retuaws.en.US.zip'
Installing '/cache/Blur_Version.21.12.34.condor_retuaws.retuaws.en.US.zip'...
Checking for MD5 file...
Skipping MD5 check: no MD5 file found
assert failed: getprop("ro.product.device") == "condor.umts" ||
  getprop("ro.build.product") == "condor.umts" ||
  getprop("ro.product.device") == "condor.umts" ||
  getprop("ro.build.product") == "condor.umts"
E: Error executing updater binary in zip '/cache/Blur_Version.21.12.34.condor_retuaws.retuaws.en.US.zip'
E: Error installing zip file '/cache/Blur_Version.21.12.34.condor_retuaws.retuaws.en.US.zip'
Done processing script file
If I go to "Reboot" and then "System" within TWRP, the phone will boot up normally, but then it reboots again a short time later and tries to install the update, which fails and goes into the TWRP menu. At this point I don't really care about the update or keeping root, I'd just like to have a working phone again. Any advice?
26th September 2014, 07:25 PM   |  #2  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Sep 2014
So I think I fixed it temporarily at least. Within TWRP I deleted /cache/Blur_Version.21.12.34.condor_retuaws.retuaws.en.US .zip, then rebooted. The phone booted up normally, and after a couple of minutes I got a full-screen notification saying "Update unsuccessful". Phone seems to be behaving normally now. Can anyone give me some guidance on what to do next? From what I've read elsewhere, the OTA updates will fail if you are non-stock. I'm running stock firmware, so I guess the problem is probably with TWRP. If I flash the stock recovery, will I then be able to do the OTA update?
27th September 2014, 12:04 PM   |  #3  
neo.ank's Avatar
Senior Member
Thanks Meter: 546
 
1,239 posts
Join Date:Joined: Apr 2011
Donate to Me
More
You need unmodified stock system and stock recovery to flash the update.

There are guides in general section to do so.
Check those out.

Tapatalk with RAZR HD
The Following User Says Thank You to neo.ank For This Useful Post: [ View ]
20th November 2014, 10:27 AM   |  #4  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Nov 2014
Root won't make the update fail. Flashing the stock recovery & insuring that you still have all the stock apps would allow the update. I hope you backed that update up before deleting it. I doubt they send another.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes