Sony Updates AOSP Sources to Android 5.0.1

Just a few days ago, Sony did an utterly fantastic job by pushing out numerous device trees for … more

Stop Your Screen From Turning Off with KeepItOn

We all know the feeling of reading a news article orrather longdocument, when our screen … more

The XDA LG QPair Developer Challenge Voting Has Begun!

It seems like it was just yesterday that weannounced that we had paired up with LGto … more

Major Update for the Sony Smartwatch 2 Brings DND and More

With the wearables landscape now dominated by Android Wear and Pebble, its … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[LOGO] Remove the bootloader unlocked warning

OP Darkshado

25th June 2014, 08:30 AM   |  #1  
Darkshado's Avatar
OP Senior Member
Montréal
Thanks Meter: 474
 
997 posts
Join Date:Joined: Apr 2011
Donate to Me
More
Hello,

This file is simply the XT1045 US retail 4.4.3 (21.23.4.peregrine_retus.retus.en.US retus) mmcblk0p27 partition dumped, cropped of about 3 MB of null content, and modified (as per this thread) so that those of us here with unlocked bootloaders aren't required to stare at the original ominous legalese, which we've agreed to anyway.

Decompress and install with:
Code:
mfastboot flash logo peregrine_logo_mod.bin
Those who want a recovery-flashable zip are free to head over to @ffosilva's thread and make one based on his.

Enjoy,

Darkshado
Attached Files
File Type: 7z peregrine_logo_mod.7z - [Click for QR Code] (303.0 KB, 1100 views)
Last edited by Darkshado; 25th June 2014 at 08:36 AM. Reason: Added source ROM info.
The Following 33 Users Say Thank You to Darkshado For This Useful Post: [ View ]
5th July 2014, 06:27 AM   |  #2  
vpnair's Avatar
Senior Member
Melbourne
Thanks Meter: 115
 
128 posts
Join Date:Joined: Jun 2010
I have 4G XT1039 (EU). I've downloaded the stock firmware RET-EU-SS_4.4.3_KXB21.14-L1.31. Should I use fastboot flash logo from the stock firmware or from the file you have provided? Will it work / is there any difference? Thanks.

EDIT: Yours worked fine. I gather XT1045 is almost identical except for 4G/LTE bands.
EDIT2: I have flashed the logo.bin file located in the zip's from these logos. Includes the stock and others. http://forum.xda-developers.com/show....php?t=2686441
Last edited by vpnair; 5th July 2014 at 07:36 AM.
The Following 4 Users Say Thank You to vpnair For This Useful Post: [ View ]
5th July 2014, 10:04 AM   |  #3  
Member
Thanks Meter: 12
 
62 posts
Join Date:Joined: Jan 2014
Quote:
Originally Posted by vpnair

EDIT: Yours worked fine. I gather XT1045 is almost identical except for 4G/LTE bands.
EDIT2: I have flashed the logo.bin file located in the zip's from these logos. Includes the stock and others. http://forum.xda-developers.com/show....php?t=2686441

Very helpful thanks for the info got it working on my XT1039
The Following User Says Thank You to Triggeh For This Useful Post: [ View ]
5th July 2014, 12:55 PM   |  #4  
reef2009's Avatar
Senior Member
Flag The Hague
Thanks Meter: 109
 
450 posts
Join Date:Joined: Aug 2010
Donate to Me
More
Confirmed working!

thnx
6th July 2014, 03:24 PM   |  #5  
Member
Thanks Meter: 9
 
46 posts
Join Date:Joined: Nov 2007
Nice, thanks for the tip Darkshado. Went with a logo from the thread vpnair linked, worked like a charm.
15th July 2014, 05:25 PM   |  #6  
Member
Flag Miami
Thanks Meter: 33
 
95 posts
Join Date:Joined: Oct 2008
More
XT1045 working great, now how about some TWRP/CWM and custom ROMS for this badboy !!
17th July 2014, 11:55 PM   |  #7  
jmcollis's Avatar
Senior Member
Flag Christchurch
Thanks Meter: 36
 
110 posts
Join Date:Joined: Apr 2012
More
Quote:
Originally Posted by rawtek

XT1045 working great, now how about some TWRP/CWM and custom ROMS for this badboy !!

Have a look in the forum. There are TWRP and CWM recoveries now available.
11th December 2014, 11:02 AM   |  #8  
cryptoncore's Avatar
Senior Member
Flag Plymouth
Thanks Meter: 81
 
130 posts
Join Date:Joined: Oct 2012
More
this works perfectly. Thank you.
14th December 2014, 03:07 PM   |  #9  
masantula's Avatar
Senior Member
Thanks Meter: 35
 
362 posts
Join Date:Joined: May 2011
Would this work even if i am on 4.4.4?

EDIT:
Never mind, worked...great job. Thanks
Last edited by masantula; 14th December 2014 at 03:12 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes