Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Moto G 4G EasyRecovery Toolkit

OP Somcom3X

25th November 2014, 11:29 PM   |  #91  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Apr 2009
More
Trying to re-lock Bootloader XT1042
I've been trying to clean up my phone for the incoming Lollipop, but so far I've had the same error as many people in trying to relock the bootloader by direct ADB/fastboot command or script (sst failed).
I have a less common variant of the Moto G 4G LTE through US Cellular, 1042 (NOT 1045) and I'm not sure if that has anything to do with it, and really not sure why that would stop a standard adb command from working. Your script does identify my phone by the correct model, the dang thing just won't relock the bootloader.
Any suggestions, directions to point me in, upcoming update in your script?
25th November 2014, 11:50 PM   |  #92  
Somcom3X's Avatar
OP Recognized Developer
Flag Metro Detroit
Thanks Meter: 2,412
 
2,698 posts
Join Date:Joined: Aug 2012
More
Quote:
Originally Posted by l0zerth

I've been trying to clean up my phone for the incoming Lollipop, but so far I've had the same error as many people in trying to relock the bootloader by direct ADB/fastboot command or script (sst failed).
I have a less common variant of the Moto G 4G LTE through US Cellular, 1042 (NOT 1045) and I'm not sure if that has anything to do with it, and really not sure why that would stop a standard adb command from working. Your script does identify my phone by the correct model, the dang thing just won't relock the bootloader.
Any suggestions, directions to point me in, upcoming update in your script?

Try using fastboot manually:
Code:
fastboot oem lock
If on windows open the tools folder and navigate to fastboot, launch a cmd prompt to that folder and type fastboot.
28th November 2014, 09:53 PM   |  #93  
occtec's Avatar
Senior Member
Flag South Australia
Thanks Meter: 586
 
1,900 posts
Join Date:Joined: Dec 2012
More
Hey guys just wondering if there is an official working twrp recovery for the xt1039 EU retail variant?
29th November 2014, 09:35 AM   |  #94  
marcussmith2626's Avatar
Recognized Contributor
Flag London
Thanks Meter: 2,637
 
4,905 posts
Join Date:Joined: Jul 2012
Quote:
Originally Posted by occtec

Hey guys just wondering if there is an official working twrp recovery for the xt1039 EU retail variant?

You can either use the one in this toolkit or you can try the version that's on the 2nd post of the cm12 thread in this dev section
The Following User Says Thank You to marcussmith2626 For This Useful Post: [ View ]
29th November 2014, 09:44 AM   |  #95  
occtec's Avatar
Senior Member
Flag South Australia
Thanks Meter: 586
 
1,900 posts
Join Date:Joined: Dec 2012
More
Quote:
Originally Posted by marcussmith2626

You can either use the one in this toolkit or you can try the version that's on the 2nd post of the cm12 thread in this dev section

Thank you very much, appreciated [emoji1]
29th November 2014, 04:20 PM   |  #96  
Junior Member
Thanks Meter: 2
 
21 posts
Join Date:Joined: Sep 2014
Glad to see this project. I extracted the recovery image only (TWRP.img) and flashed that to my XT1040. Mounts the microSD card every time. Doing a backup now.

@Somcom3X: I dig one feature that I haven't seen in other recoveries. When I'm in the recovery I actually see the phones storage on my desktop when plugged in via USB (linux mint 17). Cool feature.

Time Zone doesn't seem to be correct. Set it for Eastern w/daylight savings and the time is then set 7 hours ahead. Wonder what the fix is for that? --my phone gets its time from the network.

Date and time on the back up folders are set to the beginning of Unix time too -- 1970 -X-X-X.

I'll try wiping the cache again.

All in all its a great tool. Thanks again for the work -- you and a host of others.
1st December 2014, 06:04 AM   |  #97  
Somcom3X's Avatar
OP Recognized Developer
Flag Metro Detroit
Thanks Meter: 2,412
 
2,698 posts
Join Date:Joined: Aug 2012
More
Quote:
Originally Posted by diordnAMRZAR

Glad to see this project. I extracted the recovery image only (TWRP.img) and flashed that to my XT1040. Mounts the microSD card every time. Doing a backup now.

@Somcom3X: I dig one feature that I haven't seen in other recoveries. When I'm in the recovery I actually see the phones storage on my desktop when plugged in via USB (linux mint 17). Cool feature.

Time Zone doesn't seem to be correct. Set it for Eastern w/daylight savings and the time is then set 7 hours ahead. Wonder what the fix is for that? --my phone gets its time from the network.

Date and time on the back up folders are set to the beginning of Unix time too -- 1970 -X-X-X.

I'll try wiping the cache again.

All in all its a great tool. Thanks again for the work -- you and a host of others.

The time issue was due to my computer compiling with an incorrect time messing up the recovery clock. It those seem to reset to the 1970 year like other unix programs. My new twrp date works as of a time fix.
1st December 2014, 06:25 PM   |  #98  
Senior Member
Thanks Meter: 51
 
121 posts
Join Date:Joined: Mar 2012
More
Quote:
Originally Posted by Somcom3X

The time issue was due to my computer compiling with an incorrect time messing up the recovery clock. It those seem to reset to the 1970 year like other unix programs. My new twrp date works as of a time fix.

Sorry to ask that, as like my dad was always saying to me when i was a kid "asking is bad !" but, is there a new twrp build planned ?
I'm pretty happy with 2.8 no throttle, but the date bug is kind of a pain
(Although with apps like online nandroid backup there is no date problem).

Thanks again for all you've done for our peregrines !
1st December 2014, 10:51 PM   |  #99  
Somcom3X's Avatar
OP Recognized Developer
Flag Metro Detroit
Thanks Meter: 2,412
 
2,698 posts
Join Date:Joined: Aug 2012
More
Quote:
Originally Posted by J0kker

Sorry to ask that, as like my dad was always saying to me when i was a kid "asking is bad !" but, is there a new twrp build planned ?
I'm pretty happy with 2.8 no throttle, but the date bug is kind of a pain
(Although with apps like online nandroid backup there is no date problem).

Thanks again for all you've done for our peregrines !

My winter break I'll post a lot of new stuff. This is the worse time of the year for me with all of the cramming.
The Following User Says Thank You to Somcom3X For This Useful Post: [ View ]
2nd December 2014, 03:10 AM   |  #100  
Junior Member
Flag VILLAVICENCIO
Thanks Meter: 4
 
12 posts
Join Date:Joined: Aug 2014
More
fastboot eom lock
Quote:
Originally Posted by Somcom3X

Try using fastboot manually:

Code:
fastboot oem lock
If on windows open the tools folder and navigate to fastboot, launch a cmd prompt to that folder and type fastboot.

hola buen dia, yo tengo el XT1040 y cuando ejecuto fastboot oem lock me incica un error indicando que ejecute oem lock begin lo hago pero igual sigue desbloqueado.

gracias.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes