Post Reply Subscribe to Thread Email Thread

Moto G 4G EasyRecovery Toolkit

18th February 2015, 09:24 PM |#121  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Apr 2014
I tried rooting my phone following the instructions of shabby and got stuck because the recovery wouldn't work, there was just a blackscreen with flickers. I still could boot the system though. When I followed the instructions of someone else having the same problem as me, I kind of bricked the phone - only the bootloader was still working but still no accessable recovery.
More out of desperation I tried this Toolkit here and though it wouldn't recognize the phone (at least it didn't show one), it somehow managed to install CWM. So I think I'm gonna be able to flash a ROM, downloading now so I can't say for sure.
I'm just posting this in case someone else ends up with the same problem ... Did nobody else have the problem with the recovery just being a black screen after flashing it!?
18th February 2015, 11:18 PM |#122  
Somcom3X's Avatar
OP Recognized Developer
Flag Metro Detroit
Thanks Meter: 2,796
 
2,815 posts
Join Date:Joined: Aug 2012
More
Quote:
Originally Posted by zvz2

I tried rooting my phone following the instructions of shabby and got stuck because the recovery wouldn't work, there was just a blackscreen with flickers. I still could boot the system though. When I followed the instructions of someone else having the same problem as me, I kind of bricked the phone - only the bootloader was still working but still no accessable recovery.
More out of desperation I tried this Toolkit here and though it wouldn't recognize the phone (at least it didn't show one), it somehow managed to install CWM. So I think I'm gonna be able to flash a ROM, downloading now so I can't say for sure.
I'm just posting this in case someone else ends up with the same problem ... Did nobody else have the problem with the recovery just being a black screen after flashing it!?

Try "fastboot boot recovery.img"
19th February 2015, 05:53 PM |#123  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Apr 2014
That doesn't make sense, does it!? I've got the CWM recovery, I just can't boot.

Anyway, I flashed the stock ROM and now it's working again. Still don't know why flashing CWM in the beginning just returned the black screen ...
20th February 2015, 02:59 PM |#124  
Junior Member
Thanks Meter: 1
 
4 posts
Join Date:Joined: Apr 2011
I got stuck in a bootloop with CWM but CM12 worked fine with the TWRP, so my advice is to flash TWRP instead of CWM.

I need to try to remove the "bootloader unlocked" notice and the option to return to stock but everyone else worked great with my XT1039. And since I had no idea what I was doing this was a great help.

Cheers
6th March 2015, 11:58 AM |#125  
Senior Member
Flag Kraków
Thanks Meter: 110
 
173 posts
Join Date:Joined: May 2012
More
Mismatched partition size (recovery) error
@Somcom3X I took TWRP.img image from your toolkit (1.3.2) and installed it by hand with fastboot flash revcovery TWRP.img and I got Mismatched partition size (recovery) error. Whatever this error says TWRP works. But does everything work as it should? I don't know, I'm just asking. May I use it or there are any drawbacks? I've read somwhere that with such installed (with mismatch error) TWRP one can'd to proper backups and restores. Is it true? Thanks for explanations.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes